Package Details: openocd-git 0.10.0.r1089.g3bfe49266-1

Git Clone URL: https://aur.archlinux.org/openocd-git.git (read-only, click to copy)
Package Base: openocd-git
Description: Debugging, in-system programming and boundary-scan testing for embedded target devices (git version)
Upstream URL: http://openocd.org
Licenses: GPL
Conflicts: openocd
Provides: openocd
Submitter: veox
Maintainer: codyps (AndrevS, mdf)
Last Packager: codyps
Votes: 30
Popularity: 0.000382
First Submitted: 2012-12-30 00:55
Last Updated: 2020-02-26 00:29

Required by (9)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

abbradar commented on 2013-05-04 11:53

I'd suggest increasing epoch of the package after version naming change; it would otherwise think that old versions (201...) are newer than current ones.

veox commented on 2013-01-02 12:21

@lus: thank you for the wonderful input!

- Point taken, removed the warning.
- Agreed, I'll add all available targets.

veox commented on 2013-01-02 12:02

@lus: thank you for the wonderful input!

- Point taken, removed the warning.
- Agreed, I'll add all available targets.

ius commented on 2013-01-01 18:51

Some remarks:

- PKGBUILD won't build (due to the msg containing the warning)

- I don't think the warning is neccesary; git PKGBUILDs pulling git repositories is expected behavior, whether that be a git submodule or not. I'd like to suggest you just remove the warning/sleep..

- Some newer targets are missing (eg. ti-icdi, only in git, reason why I grabbed this package), perhaps we should add all targets as a default?

- You can eliminate shipping version.texi (which specifies a bogus version anyhow) by passing --enable-maintainer-mode

nickoe commented on 2012-10-19 18:58

djvinz, thank you very much, I have now fixed it.

I like easy fixes :=)

nickoe commented on 2012-10-19 18:57

djvinz, thank you very much, I have not fixed it.

maximevince commented on 2012-10-19 17:16

awesome package!
Just a type in the PKGBUILD:
--enable-usb_flaster_libftdi \
ought to be:
--enable-usb_blaster_libftdi \

thanks!

nickoe commented on 2012-03-31 21:51

Updated the package
- added the --enable-osbdm
- rmoved manual jimtcl build
- updated reference to automake

sergej commented on 2012-03-27 23:39

Please add --enable-osbdm, conflicts with jimtcl package.

Also automake workaround seems not needed anymore.

nickoe commented on 2012-01-26 20:59

@unkier: I added the stlink interface

@javsalgar: I have now made a temporary fix, to make it work. It has indeed something to do with automake. Now it works with automake 1.10. If you know how to make it work with the current automake, please inform me.