Package Details: openni2 2.2.0-1

Git Clone URL: https://aur.archlinux.org/openni2.git (read-only)
Package Base: openni2
Description: Framework for sensor-based Natural Interaction
Upstream URL: https://github.com/occipital/OpenNI2/
Keywords: openni2
Licenses: Apache-2.0
Submitter: bchretien
Maintainer: acxz
Last Packager: acxz
Votes: 5
Popularity: 0.81
First Submitted: 2015-08-28 01:42
Last Updated: 2019-09-29 05:40

Sources (8)

Latest Comments

acxz commented on 2019-09-29 05:41

Package fixed up based on git version of the package.

1CatchMe1 commented on 2017-04-02 19:27

@tuxce
thanks, worked with clang.

tuxce commented on 2016-09-08 07:15

Build fails with gcc 6.
As a workaround, you can use clang :


git clone https://aur.archlinux.org/openni2.git
cd openni2
CXX=clang++ makepkg -si



neTpK commented on 2016-06-27 10:51

The errors occured below are because of non-supported compiler.

Install gcc-4.x to compile.

neTpK commented on 2016-06-23 06:19

4-Release/OpenNI2/Drivers -lXnLib -ldl -lpthread -lDepthUtils -lrt -lusb-1.0 -ludev -Wl,--no-undefined -shared
make[1]: Leaving directory '/tmp/yaourt-tmp-petterk/aur-openni2/src/OpenNI2-2.2-beta2/Source/Drivers/PS1080'
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build openni2.

ngoonee commented on 2015-12-10 23:56

Considering there's no actual changes to the PKGBUILD, why not just put a note saying a rebuild is needed rather than bumping pkgrel? The old ABI still works after all....