Package Details: openmodelica-git 1.16.0.dev.r590.g8f5710f752-2

Git Clone URL: https://aur.archlinux.org/openmodelica-git.git (read-only, click to copy)
Package Base: openmodelica-git
Description: The Open Source Modelica Suite
Upstream URL: https://openmodelica.org
Licenses: OSMC-PL
Conflicts: openmodelica, openmodelica-dev, openmodelica-svn
Provides: openmodelica
Submitter: Xwang
Maintainer: ElMastro
Last Packager: ElMastro
Votes: 10
Popularity: 0.083533
First Submitted: 2015-06-20 11:21
Last Updated: 2021-02-13 23:23

Dependencies (18)

Required by (0)

Sources (10)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

Scimmia commented on 2020-08-12 23:19

Replacing one terrible PKGBUILD with an even more terrible one doesn't help. Read the VCS package guidelines in the wiki.

Xwang commented on 2020-08-12 17:35

@ElMaestro Can you please update the PKGBUILD with this one https://pastebin.com/XyYtS2v8 ?

Xwang commented on 2020-08-12 16:07

As they closed the bug, I asked for help in the forum: https://bbs.archlinux.org/viewtopic.php?pid=1920334#p1920334

Xwang commented on 2020-08-12 16:00

@ElMaestro you should update the PKGBUILD with the one in the pastebin in the 2008-08-10 comment so that if they decide to reopen the bug, they will find the correct PKGBUILD and not the old one.

ElMastro commented on 2020-08-12 14:36

https://bugs.archlinux.org/task/67563

Xwang commented on 2020-08-10 19:26

These lines:

... rmdir usr/OMSens mv "${pkgdir}/usr/share/openmodelica/icons/" "${pkgdir}/opt/OpenModelica/share/icons/" ...

complain that such files/folders do not exist so I had to comment them out. Still I had to build outside the makepkg due to the qwt issue.

ElMastro commented on 2020-08-10 14:42

The PKGBUILD on https://pastebin.com/G99mw9Xg should be a bit better. @Xwang, I don't know how to help you, because the file needed is in the first row. Perhaps you could try to reinstall the package or even better ask in the forum.

Soon I will create the bug on archlinux.org

Xwang commented on 2020-08-10 13:23

pacman -Ql qwt | grep qwt.plot.h gives:

qwt /usr/include/qwt/qwt_plot.h qwt /usr/include/qwt/qwt_plot_histogram.h qwt /usr/share/doc/qwt/html/class_qwt_plot.html qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram-members.html qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram.html qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram.js qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram__inherit__graph.map qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram__inherit__graph.md5 qwt /usr/share/doc/qwt/html/class_qwt_plot_histogram__inherit__graph.png

ElMastro commented on 2020-08-10 11:46

@Xwang, sorry for the long delay.

I tried the PKGBUILD, ends up with the same error. It requires the package lib32-zlib, I'm going to modify the PKGBUILD according to this. Lso I will insert the other things you suggested. I gave a look to the paraview-opt.sh script file, we could do a script like it, however, being it two rows probably could be more pragmatic to add them on top of the PKGBUILD.

Would you like to post what the command "pacman -Ql qwt | grep qwt.plot.h" returns?

Xwang commented on 2020-07-30 22:04

I was just giving a look at the paraview-opt package and I was wondering if it is the case to create a bash script for openmodelica similar to the paraview.sh so that to have a fully configured openmodelica installation