Package Details: openlara-git r200.e14e661-1

Git Clone URL: https://aur.archlinux.org/openlara-git.git (read-only, click to copy)
Package Base: openlara-git
Description: Classic Tomb Raider open-source engine
Upstream URL: https://github.com/XProger/OpenLara
Licenses: unknown
Conflicts: openlara
Provides: openlara
Submitter: jle64
Maintainer: None
Last Packager: jle64
Votes: 4
Popularity: 0.000000
First Submitted: 2017-04-24 14:33
Last Updated: 2017-04-24 14:33

Latest Comments

jle64 commented on 2019-10-13 23:14

@noabody: The package has no maintainer, maybe you could take it over to push your version of the PKGBUILD ?

noabody commented on 2019-10-13 06:20

I've had good luck with the SDL2 version while building on Ubuntu. PKGBUILD would look similar to this:

pkgname=openlara-git
_pkgname=openlara
pkgver=r1048.1b46961
pkgrel=1
pkgdesc="Classic Tomb Raider open-source engine"
arch=('any')
url="https://github.com/XProger/OpenLara"
license=('BSD-2-Clause')
makedepends=('git' 'clang')
depends=('libx11' 'libgl' 'libpulse' 'sdl2')
provides=($_pkgname)
conflicts=($_pkgname)
source=('openlara::git://github.com/XProger/OpenLara.git')
md5sums=('SKIP')

pkgver() {
    cd "$srcdir/$_pkgname"
    printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}

build() {
    cd "$srcdir/$_pkgname/src/platform/sdl2"
    ./build.sh
}

package() {
    mkdir -p "$pkgdir/usr/bin" "$pkgdir"/usr/lib/openlara
    install -m 755 "$srcdir/$_pkgname/src/platform/sdl2/OpenLara" "$pkgdir/usr/lib/openlara/OpenLara"
    # use a wrapper as the program needs its CWD to be the directory containing the data files
    echo -e '#!/bin/sh\nset -eu\ncd /usr/share/openlara\n/usr/lib/openlara/OpenLara $@' > "$pkgdir/usr/bin/openlara"
    chmod 0755 "$pkgdir/usr/bin/openlara"
}

rafaelff commented on 2018-01-17 19:05

It fails in package() because the files LEVEL2.PSX, 05.ogg and 008.ogg are not provided by the upstream source.