Package Details: openhab2 2.5.5-2

Git Clone URL: https://aur.archlinux.org/openhab2.git (read-only, click to copy)
Package Base: openhab2
Description: openHAB2 open source home automation software
Upstream URL: http://www.openhab.org/
Licenses: EPL
Conflicts: openhab-addons, openhab-beta, openhab-runtime
Submitter: ChaosKid42
Maintainer: ChaosKid42
Last Packager: ChaosKid42
Votes: 19
Popularity: 1.23
First Submitted: 2017-05-03 13:24
Last Updated: 2020-05-23 18:52

Latest Comments

1 2 3 Next › Last »

ChaosKid42 commented on 2020-05-23 18:55

@rutorai.pf,jenmonk: Maybe it helps to add the user "openhab" to the audio system group. I updated the package accordingly. If you already installed openhab2 then you need to add the openhab user to the audio group by yourself using something like sudo usermod -a -G audio openhab

jenmonk commented on 2020-05-22 21:05

same issue as rutorai.pf

rutorai.pf commented on 2020-04-03 09:06

Hello,

First, thanks for this package. It works well, but I've just one problem : no sound when I configure "System speakers". Anybody have the same problem ? Any special configuration I should be aware of with this package ?

I want to precise that, except with OpenHAB, sound works perfectly (firefox, audacious, hdmi, speakers, headphones)

Thanks and regards.

zynex commented on 2020-01-21 14:11

Stable release updated to 2.5.1, checksum 79907c05d1fa2b64a843dc1e2f7f46a8f3248f1d2d583604e3538ae5af7202de.

One thought thou, as for now you have to copy the addons file manually. Any thoughts about including it here or maybe have it as an additional build so it reflect the installed version?

iegubkin commented on 2020-01-17 02:22

In order to update from 2.4 to 2.5 I had to delete two folders and their contents:

/var/lib/openhab2/tmp
/var/lib/openhab2/cache

I also deleted the file:

/var/lib/openhab2/config/org/openhab/addons.config

I then reinstalled my bindings (zwave) and actions (xmpp). Items do not need to be reinstalled.

Teyro commented on 2019-12-25 21:12

Cant start it on ArchArm... :(

Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:378) Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:332) Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:257) Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388) Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025) Dez 25 22:10:44 teyropi start.sh[20347]: at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964) Dez 25 22:10:44 teyropi start.sh[20347]: at java.util.concurrent.FutureTask.run(FutureTask.java:266) Dez 25 22:10:44 teyropi start.sh[20347]: at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) Dez 25 22:10:44 teyropi start.sh[20347]: at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) Dez 25 22:10:44 teyropi start.sh[20347]: at java.lang.Thread.run(Thread.java:748)

doits commented on 2019-12-19 11:53

@JohnyRI I had the same problem, I think deleting everything in /var/lib/openhab2/tmp/ did the trick for me. Had to reinstall my bindings though, but after this everything seems to work now.

JohnyRi commented on 2019-12-19 08:04

Is anyone else getting the following error after upgrading to v 2.5.0?

[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-standard': No matching features for openhab-package-standard/0

Googling suggested two actions: change package from standard to expert in /etc/openhab2/services/addons.cfg and deleting file /var/lib/openhab2/config/org/openhab/addons.config

I tried both and none of the suggested approaches worked. The only solution is to downgrade back to 2.4.0.

bebR commented on 2018-05-20 09:57

For serial devices to work, like RFXCOM or MySensors' serial gateway, the openhab user must be added to the uucp group.

@ChaosKid42: Could be add the openhab user to the uucp group? Because I think that any USB device (Zwave, MySensors, RFXCOM etc.) will get this issue. Thanks.

ChaosKid42 commented on 2018-04-11 16:42

@Frans-Willem: Done