Package Details: opencpn-git 5.2.0.r42.g14628ba0e-1

Git Clone URL: https://aur.archlinux.org/opencpn-git.git (read-only, click to copy)
Package Base: opencpn-git
Description: Open Source Chart Plotting / Marine Navigation - Git version
Upstream URL: http://opencpn.org
Licenses: GPL2
Conflicts: opencpn
Provides: opencpn
Submitter: gromain
Maintainer: gromain
Last Packager: gromain
Votes: 0
Popularity: 0.000000
First Submitted: 2019-11-19 11:29
Last Updated: 2020-08-11 12:27

Latest Comments

glenjo commented on 2020-07-13 17:01

So I finally got Opencpn compiled and running BUT I had to download and compile wxWidgets from source, and Opencpn from source too. I think the error results from having wxWidgets compiled by a different version of gcc. I think, I'm not sure.

glenjo commented on 2020-07-02 04:55

I just compiled and ran and had the same error: (opencpn:1005990): Gtk-ERROR **: 21:51:40.420: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported Trace/breakpoint trap (core dumped)

The package was opencpn-git-5.1.529.Beta.r97.gd195ce2ca-1-x86_64.pkg.tar.xz (I'm hoping that contains the commit information you need to make sense of all this!) Thanks for your work, and let me know if there is anything you would like me to try.

gromain commented on 2020-06-29 07:51

Bug has been solved upstream, package has been updated. Please test on your side.

gromain commented on 2020-06-28 10:24

I think the problem comes from commit 116a629f8. I've reported the problem upstream.

In the meantime, I'll update the package to build on commit af5f5b644 which works for me. Please report if this breaks the build on your system too.

glenjo commented on 2020-06-17 23:10

I think that the error comes about due to the upgrade to gcc-10, and as you mentioned, the fact that wxwidgets is still compiled under gcc-9. I've been looking around for the compiler switch that I can add to /etc/makepkg.conf that turns off this error, but so far no joy.

gromain commented on 2020-06-16 21:34

After cleaning the cache and build folder, I've got a new error on startup: (opencpn:17479): Gtk-CRITICAL **: 23:33:29.220: gtk_window_resize: assertion 'height > 0' failed

gromain commented on 2020-06-16 20:55

I don't know where this error is coming from, I'm still investigating. Looks like wxgtk id not the same version, but it is still. So yeah...

glenjo commented on 2020-06-08 18:05

Compiles clean, but errors when executed: The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).

(opencpn:304385): Gtk-ERROR **: 10:48:39.629: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported Trace/breakpoint trap (core dumped)

gromain commented on 2020-03-31 17:11

Thanks for the heads-up! It's been added in the latest version of the PKGBUILD!

Npa commented on 2020-03-23 13:45

Hello thanks for your work, no problem to build the package but lsb-release is needed. Perhaps lsb-release should be added as dependency ?