Package Details: openconnect-palo-git 7.08.r84.g91025a3-1

Git Clone URL: https://aur.archlinux.org/openconnect-palo-git.git (read-only)
Package Base: openconnect-palo-git
Description: VPN client for Palo Alto GlobalProtect VPN
Upstream URL: http://www.infradead.org/openconnect.html
Licenses: GPL
Conflicts: openconnect
Provides: openconnect
Submitter: BaconHunter
Maintainer: ljmf00
Last Packager: BaconHunter
Votes: 9
Popularity: 0.349230
First Submitted: 2017-02-20 01:11
Last Updated: 2017-02-20 01:11

Required by (11)

Sources (1)

Latest Comments

tritron commented on 2019-07-16 16:22

Compiling this is broken now few packages had been upgraded to higher version libhogweed.so.4 is now libhogweed.so.5 and libhogweed.so.4 undefined reference to nettle_base64_decode_update@NETTLE_6' /usr/bin/ld: /usr/lib/libstoken.so: undefined reference tonettle_aes_decrypt@NETTLE_6' /usr/bin/ld: /usr/lib/libstoken.so: undefined reference to nettle_rsa_private_key_clear@HOGWEED_4' /usr/bin/ld: /usr/lib/libstoken.so: undefined reference tonettle_aes_set_decry

dabier commented on 2019-03-05 18:41

Got the note from https://github.com/dlenski/openconnect: OpenConnect client has been extended to support Palo Alto Networks' GlobalProtect VPN. So the distro package openconnect should work out of the box as long as it is > v8.00.

phoenixuk commented on 2019-02-15 22:01

It looks like the official 'openconnect' package now provides 'libopenconnect.so', which the official 'networkmanager-openconnect' now explicitly depends upon - meaning 'openconnect-palo-git' no longer satisfies the dependencies for 'networkmanager-openconnect'. I've locally tested updating the PKGBUILD for this package to declare it providing 'libopenconnect.so' and this appears to work.

bouk commented on 2018-11-02 17:55

Installing this package failed for me, as the 'stoken' and 'trousers' packages both wouldn't install for me. These are optional dependencies, and updating the PKGBUILD to make them so allowed me to install it successfully.

btaidm commented on 2017-11-09 19:58

To have openconnect dns work with systemd-resolv, an updated vpnc-script is at http://git.infradead.org/users/dwmw2/vpnc-scripts.git/blob_plain/HEAD:/vpnc-script.