Package Details: openblok 0.8.2-3

Git Clone URL: https://aur.archlinux.org/openblok.git (read-only, click to copy)
Package Base: openblok
Description: A customizable, cross platform, open-source falling block game, packed with a bunch of features.
Upstream URL: https://github.com/mmatyas/openblok
Licenses: GPL3
Submitter: Kicer
Maintainer: Kicer
Last Packager: Kicer
Votes: 2
Popularity: 0.34
First Submitted: 2019-03-09 11:48
Last Updated: 2020-05-20 13:48

Latest Comments

emceebois commented on 2020-05-20 17:05

Perfect, thank you very much. I was able to build this in chroot using gcc-8.

Kicer commented on 2020-05-20 13:11

There are various build errors with gcc-10. I have switched build to use gcc-8. It should work now.

emceebois commented on 2020-05-20 00:31

https://pastebin.com/fPmyCptD

Kicer commented on 2020-05-19 21:24

I am using gcc in version 9.3.0.

Please copy more lines from output

emceebois commented on 2020-05-19 21:08

Hmm, I'm still getting "unrecognized command-line option ‘-Wshorten-64-to-32’" when I run makepkg -si -- what compiler are you using?

Kicer commented on 2020-05-19 17:48

I have updated package to the latest version, please try now.

emceebois commented on 2020-05-19 04:30

Per the readme on the project's github, the following dependencies are missing from the PKGBUILD, and can cause failed builds.

C++11 supporting compiler (GCC 4.9 or better)
SDL2, SDL2_image, SDL2_mixer, SDL2_ttf
optional: gcov, lcov (for generating test coverage report)

When I manually added those dependencies to the PKGBUILD, I still got a failed build with the error "unrecognized command-line option ‘-Wshorten-64-to-32’" (this despite the fact that CMake checked for this feature and found it before starting the build).

Could the maintainer please explain what version of GCC and CMake were on their system when this build worked? This may require building in a chroot with specific versions.