Package Details: openbazaar 2.4.9-1

Git Clone URL: https://aur.archlinux.org/openbazaar.git (read-only, click to copy)
Package Base: openbazaar
Description: Front-end Electron application for talking with the OpenBazaar daemon
Upstream URL: https://github.com/OpenBazaar/openbazaar-desktop
Keywords: openbazaar openbazaar-client openbazaar-gui
Licenses: MIT
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 32
Popularity: 0.48
First Submitted: 2014-09-03 16:05
Last Updated: 2020-12-05 16:20

Dependencies (3)

Required by (0)

Sources (3)

Latest Comments

1 2 3 Next › Last »

Gio commented on 2020-09-29 02:40

HI @robertfoster.

Thank You for providing this package, however...

As reported by @postfinem as well, I experiencing the following error during the installation of the package:

"Running hooks... ERROR:root:Failed to get version info: Git command 'git log -1 --format=%H %ct --grep=^Change-Id: HEAD' in /var/tmp/pamac-build-gio/electron6/src/src failed: rc=0, stdout='' stderr='' ERROR:root:Failed to get version info: Git command 'git log -1 --format=%H %ct --grep=^Change-Id: HEAD' in /var/tmp/pamac-build-gio/electron6/src/src failed: rc=0, stdout='' stderr='' 0> Downloading src/third_party/node/node_modules.tar.gz... 0> Extracting 5942 entries from src/third_party/node/node_modules.tar.gz to src/third_party/node/node_modules Downloading 1 files took 112.783171 second(s) <stdin>:1955: trailing whitespace.

<stdin>:1958: trailing whitespace.

warning: 2 lines add whitespace errors. node: error while loading shared libraries: libicui18n.so.65: cannot open shared object file: No such file or directory ==> ERROR: A failure occurred in prepare(). Aborting..."

Thank YOU.

fairlix commented on 2020-08-30 18:40

Hey,

I could not connect to my local openbazaar server using this package. I would always get an error "Error: Failed to connect to [connection name]" after trying to connect to my properly running local openbazaar daemon. I checked for any packages on loopback with the respective port (4002) and none were recorded when trying to connect.

I switched over to the AUR package openbazaar-bin which works and which shows packages in wireshark.

postfinem commented on 2020-05-01 02:41

I get node: error while loading shared libraries: libicui18n.so.67: cannot open shared object file: No such file or directory when I try to build.

kusky commented on 2019-07-03 19:07

i get this error $ openbazaar xdg-settings: unknown desktop environment

the window is blank

needle8420 commented on 2018-10-10 12:11

Error: Cannot find module 'spdx-correct'

solution:

sudo npm -g install spdx-correct

flacks commented on 2018-05-04 04:49

Could you please add upx as a makedepends? I got no verbosity in the error whatsoever during build, but tried CameronNemo's solution and the build succeeded. Seems like a definite build dependency.

TomZander commented on 2018-03-15 12:21

Could you perhaps try to build this in a clean VM? It may be missing some dependencies.

It fails in the 'build()' step for me. ==> ERROR: A failure occurred in build(). Aborting...

CameronNemo commented on 2018-02-20 05:00

I saw an error.

Error: Cannot find the upx binary required for compressing binaries

I installed upx and the error went away.

UNIcodeX commented on 2018-02-17 21:41

I did not get prompted to choose which currencies to accept payment in. Is anyone else having that issue? What file could I edit or switch could I use to cause it to prompt me to allow acceptance of different currencies?

100best commented on 2017-02-03 08:53

The "md5sums" needs to be updated, also why doesn't this package use the latest version of electron?