Package Details: oolite 1.88-1

Git Clone URL: https://aur.archlinux.org/oolite.git (read-only, click to copy)
Package Base: oolite
Description: A space-sim based on the classic Elite
Upstream URL: http://www.oolite.org/
Keywords: elite game role-playing space trading
Licenses: GPL2
Submitter: Barthalion
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 6
Popularity: 0.80
First Submitted: 2018-01-16 18:40
Last Updated: 2018-12-13 10:10

Pinned Comments

SanskritFritz commented on 2019-05-19 19:59

https://github.com/OoliteProject/oolite/issues/338 This package does not build at the moment. You can however use the binary package from https://github.com/OoliteProject/oolite/releases

Latest Comments

stas-t commented on 2019-12-29 13:53

After some years I've built oolite again and the build was successful for me. However I've discovered that it depends on espeak (unmaintained by original author) instead of espeak-ng (active fork).

Here is a simple patch that makes oolite build against espeak-ng:

diff --git a/.SRCINFO b/.SRCINFO
index [`80402d0`](https://aur.archlinux.org/cgit/aur.git/commit/?h=oolite&id=80402d0)..2bceebd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = oolite
        depends = gnustep-gui
        depends = sdl_mixer
        depends = glu
-       depends = espeak
+       depends = espeak-ng
        depends = nspr
        depends = python2
        depends = icu
diff --git a/PKGBUILD b/PKGBUILD
index [`b4b4eef`](https://aur.archlinux.org/cgit/aur.git/commit/?h=oolite&id=b4b4eef)..a9b1700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgdesc="A space-sim based on the classic Elite"
 arch=('x86_64')
 url="<http://www.oolite.org/>"
 license=('GPL2')
-depends=('gnustep-gui' 'sdl_mixer' 'glu' 'espeak' 'nspr' 'python2' 'icu' 'gnustep-base' 'openal')
+depends=('gnustep-gui' 'sdl_mixer' 'glu' 'espeak-ng' 'nspr' 'python2' 'icu' 'gnustep-base' 'openal')
 makedepends=('gnustep-make' 'curl' 'zip' 'mesa' 'gcc-objc')
 #options=(makeflags)
 source=("oolite"
@@ -22,6 +22,7 @@ build() {
   unset CPPFLAGS
   #sed -i '/void png_error/d' src/Core/Materials/OOPNGTextureLoader.m
   sed -i "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions/" GNUmakefile
+  sed -i "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" GNUmakefile
   source /usr/share/GNUstep/Makefiles/GNUstep.sh
   make -f Makefile release-deployment
 }

SanskritFritz commented on 2019-05-19 19:59

https://github.com/OoliteProject/oolite/issues/338 This package does not build at the moment. You can however use the binary package from https://github.com/OoliteProject/oolite/releases

kcallis commented on 2019-05-18 19:49

@evorster I am suffering with the exact same error. I know that I have installed on another machine and had no issues.

evorster commented on 2019-05-12 08:05

I get the following error when trying to build OOlite:

-------------snip--------------- ./methodjit/MethodJIT.cpp:78:9: note: in expansion of macro ‘JS_STATIC_ASSERT’ JS_STATIC_ASSERT(offsetof(JSStackFrame, ncode_) == 0x28); ^~~~~~~~~~~~~~~~ ../methodjit/MethodJIT.cpp: At global scope: ../methodjit/MethodJIT.cpp:192:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:193:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:192:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:239:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:240:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:239:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:259:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:260:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:259:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:284:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:285:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:284:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
In file included from ../jsval.h:48, from ../jspubtd.h:47, from ../jsprvtd.h:57, from ../jscntxt.h:55, from ../methodjit/MethodJIT.h:42, from ../methodjit/MethodJIT.cpp:39: ../jsutil.h: In instantiation of ‘void js::PodZero(T) [with T = js::analyze::Bytecode]’: ../jsanalyze.h:87:21: required from here ../jsutil.h:422:11: warning: ‘void memset(void*, int, size_t)’ clearing an object of non-trivial type ‘struct js::analyze::Bytecode’; use assignment or value-initialization instead [-Wclass-memaccess] memset(t, 0, sizeof(T)); ~~~~~~^~~~~~~~~~~~~~~~~ In file included from ../methodjit/Compiler.h:43, from ../methodjit/MethodJIT.cpp:44: ../jsanalyze.h:56:8: note: ‘struct js::analyze::Bytecode’ declared here struct Bytecode ^~~~~~~~ make[3]: [../config/rules.mk:1477: MethodJIT.o] Error 1 make[3]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88/deps/mozilla/js/src/build-release' make[2]: [../config/rules.mk:754: default] Error 2 make[2]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88/deps/mozilla/js/src/build-release' make[1]: [libjs.make:45: deps/mozilla/js/src/build-release/build_stamp] Error 2 make[1]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88' make: [Makefile:117: LIBJS] Error 2 ==> ERROR: A failure occurred in build().

SanskritFritz commented on 2018-12-17 08:43

I don't know what could be the problem, oolite builds fine here. Sorry.

Markus.N commented on 2018-12-16 21:22

Unfortunately, I can not build the package on my system: Error message: "checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required." I have python2 (2.7.15) and python3 (3.7.1) installed, and python3 seems to be the default. Patching "#!/usr/bin/env python" (and similar) to "#!/usr/bin/env python2" in all python files did not help.