Package Details: ola-git 0.10.6.r1355.g671e66b85-1

Git Clone URL: https://aur.archlinux.org/ola-git.git (read-only)
Package Base: ola-git
Description: The Open Lighting Architecture (OLA) provides a plugin framework for distributing DMX512 control signals on Mac and Linux
Upstream URL: https://www.openlighting.org/ola/
Licenses: GPL2, LGPL2.1
Conflicts: ola
Provides: ola
Submitter: schlmm
Maintainer: schlmm
Last Packager: schlmm
Votes: 13
Popularity: 0.003536
First Submitted: 2012-06-25 17:00
Last Updated: 2018-06-25 06:33

Required by (2)

Sources (1)

Latest Comments

1 2 3 Next › Last »

yar commented on 2019-06-25 23:55

Someone on that github thread posted a patch which seems to work for me. If you want to try it, you can replace the source line with my fork:

source=("git+https://github.com/yardenac/ola.git#branch=pb37")

schlmm commented on 2019-04-01 10:26

you have to downgrade protobuf to 3.6 until there is support for protobuf 3.7

see https://github.com/OpenLightingProject/ola/issues/1550

paum commented on 2019-03-31 15:26

can't build

schlmm commented on 2018-08-13 15:01

should be fixed when https://github.com/OpenLightingProject/ola/pull/1467 gets merged

for now you can use
source=('git+https://github.com/peternewman/ola.git#branch=protobuf-3.6')
as source

kwe commented on 2018-08-10 18:14

Not building for me:

checking for libprotobuf... yes
checking protobuf library version... 3.6.0
checking for protoc... /usr/bin/protoc
checking protoc version... 3.6.0
checking google/protobuf/compiler/command_line_interface.h usability... no
checking google/protobuf/compiler/command_line_interface.h presence... yes
configure: WARNING: google/protobuf/compiler/command_line_interface.h: present but cannot be compiled
configure: WARNING: google/protobuf/compiler/command_line_interface.h: check for missing prerequisite headers?
configure: WARNING: google/protobuf/compiler/command_line_interface.h: see the Autoconf documentation
configure: WARNING: google/protobuf/compiler/command_line_interface.h: section "Present But Cannot Be Compiled"
configure: WARNING: google/protobuf/compiler/command_line_interface.h: proceeding with the compiler's result
configure: WARNING: ## --------------------------------------------- ##
configure: WARNING: ## Report this to open-lighting@googlegroups.com ##
configure: WARNING: ## --------------------------------------------- ##
checking for google/protobuf/compiler/command_line_interface.h... no
configure: error: Cannot find the protoc header files

alphancioglu commented on 2018-07-12 08:11

Cleaning the package manager cache and installing fixed it.

schlmm commented on 2018-07-12 07:42

hmm configure.ac is there:
https://github.com/OpenLightingProject/ola/blob/master/configure.ac

and build works here

alphancioglu commented on 2018-07-12 07:28

I am getting error during makepkg:

==> Starting pkgver()... ==> Removing existing $pkgdir/ directory...
==> Starting build()...
autoreconf: 'configure.ac' or 'configure.in' is required
==> ERROR: A failure occurred in build().
Aborting...
2018-07-12 10:24:07,979 - wrappers - makepkg - ERROR - makepkg query ['makepkg', '-cf', '--noconfirm'] failed in directory /home/alp/.cache/aurman/ola-git

schlmm commented on 2018-06-25 06:36

yep you are right. i fixed the PKGBUILD

amael commented on 2018-06-16 13:18

No, it was not. And it worked with it.

But I think it shouldn't be an optionnal dependency as it is required to build as in the default pkgbuild.