Package Details: okular-no-purpose 20.08.3-2

Git Clone URL: https://aur.archlinux.org/okular-no-purpose.git (read-only, click to copy)
Package Base: okular-no-purpose
Description: Okular, a document viewer, without the dependency on purpose. This disables the share menu
Upstream URL: https://kde.org/applications/graphics/okular/
Licenses: GPL, LGPL, FDL
Groups: kde-applications, kde-graphics
Conflicts: okular
Provides: okular
Replaces: okular
Submitter: bepaald
Maintainer: bepaald
Last Packager: bepaald
Votes: 2
Popularity: 0.001513
First Submitted: 2017-12-19 22:54
Last Updated: 2020-11-16 22:48

Dependencies (26)

Required by (12)

Sources (3)

Latest Comments

sandsmark commented on 2020-04-16 12:39

The checksum is out of date again.

The reason seems to be that the git version on invent.kde.org has been upgraded from git 2.25.1 to 2.26.0 (changing the last line in the patch).

bepaald commented on 2020-03-16 10:47

@frankspace Yes, confirmed. I don't know what happened, it worked fine before. The normal package (https://www.archlinux.org/packages/extra/x86_64/okular/) has the same patch and signature and also fails. I'll file a bug there. This package will be fixed as soon as the original is fixed (if not before, but I do not yet know what to do).

EDIT Should be fixed now, thanks to the quick response by Antonio Rojas

frankspace commented on 2020-03-15 15:50

The CVE-2020-9359.patch file is failing the validity check for me.

kris7t commented on 2019-12-25 17:31

Sorry, I think I managed to debug my build issue. I installed gtkplatform once to try out Qt on Wayland through GTK, and it seems it causes issues with building QtQuick apps. After removing gtkplatform, Okular built just fine.

bepaald commented on 2019-12-17 22:51

@kris7t: That's odd, I can't reproduce that, it builds and installs just fine here. The changes I've made to the PACKAGEBUILD from the original package are really minimal. Do you get the same failure when you try to build that? How are you building exactly?

kris7t commented on 2019-12-16 21:35

Configure fails for me with the error message

CMake Error at /usr/lib64/cmake/Qt5Gui/Qt5Gui_QGtkIntegrationPlugin.cmake:4 (_populate_Gui_plugin_properties):
  _populate_Gui_plugin_properties Macro invoked with incorrect arguments for
  macro named: _populate_Gui_plugin_properties
Call Stack (most recent call first):
  /usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake:213 (include)
  /usr/lib64/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake:112 (find_package)
  /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package)
  CMakeLists.txt:39 (find_package)