Package Details: okular-git 19.04.1.r43.gb1c30cd0e-1

Git Clone URL: https://aur.archlinux.org/okular-git.git (read-only, click to copy)
Package Base: okular-git
Description: Universal document viewer
Upstream URL: http://kde.org/applications/graphics/okular/
Keywords: kde kf5
Licenses: GPL
Conflicts: kdegraphics-okular, okular, okular-frameworks-git
Provides: okular
Replaces: okular-frameworks-git
Submitter: Sevenseven
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 40
Popularity: 0.114470
First Submitted: 2011-07-11 05:22
Last Updated: 2019-05-26 20:40

Required by (12)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

tajidinabd commented on 2014-12-26 14:46

im getting errors when i try to build this package
its complaining about the build function

this is the error i get

generators/ooo/CMakeFiles/okularGenerator_ooo.dir/build.make:54: die Regel für Ziel „generators/ooo/CMakeFiles/okularGenerator_ooo.dir/converter.cpp.o“ scheiterte
make[2]: *** [generators/ooo/CMakeFiles/okularGenerator_ooo.dir/converter.cpp.o] Fehler 1
CMakeFiles/Makefile2:1260: die Regel für Ziel „generators/ooo/CMakeFiles/okularGenerator_ooo.dir/all“ scheiterte
make[1]: *** [generators/ooo/CMakeFiles/okularGenerator_ooo.dir/all] Fehler 2
Makefile:127: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2


sl1pkn07 commented on 2014-12-08 21:11

missing -DQca-qt5_DIR=/usr/lib/cmake/Qca in cmake options

greetings

sl1pkn07 commented on 2014-12-07 04:15

please add

sed 's|QCA2 "2.0.0"|Qca-qt5 "2.0.0"|g' -i okular/generators/ooo/CMakeLists.txt

in prepare()

and

-DQca-qt5_DIR=/usr/lib/cmake/Qca

in a cmake options to build with qca-qt5(-git) >=2.1.0 (in makedepends)

greetings

sl1pkn07 commented on 2014-12-05 22:52

okular-frameworks-git E: Dependency desktop-file-utils detected and not included (needed for update-desktop-database)
okular-frameworks-git E: Dependency ebook-tools detected and not included (libraries ['usr/lib/libepub.so.0'] needed in files ['usr/lib/qt/plugins/okularGenerator_epub.so'])


greetings

andre.vmatos commented on 2014-11-23 02:18

Even with libkexiv2-frameworks-git installed, I'm getting compile error:
Linking CXX shared module okularGenerator_kimgio.so
...
/usr/bin/ld: cannot find -lKF5::Kexiv2
collect2: error: ld returned 1 exit status
generators/kimgio/CMakeFiles/okularGenerator_kimgio.dir/build.make:111: recipe for target 'generators/kimgio/okularGenerator_kimgio.so' failed
make[2]: *** [generators/kimgio/okularGenerator_kimgio.so] Error 1
CMakeFiles/Makefile2:664: recipe for target 'generators/kimgio/CMakeFiles/okularGenerator_kimgio.dir/all' failed
make[1]: *** [generators/kimgio/CMakeFiles/okularGenerator_kimgio.dir/all] Error 2

sl1pkn07 commented on 2014-11-12 15:21

please, can add libkexiv2-frameworks-git to depends?

greetings

Nierro commented on 2014-11-08 21:59

Ok, thanks for the quick explanation!

arojas commented on 2014-11-06 15:30

@Nierro that wouldn't be right, applications that really need kdegraphics-okular (like kbibtex) won't work with the KF5 version, so it doesn't really "provide" it. But actually okular shouldn't be a dependency of calligra-words at all, you should report it to the bug tracker.

Nierro commented on 2014-11-06 13:56

Can you add a "provides=kdegraphics-okular"?
looking for inter-conflicts...
:: okular-frameworks-git and kdegraphics-okular are in conflict. Remove kdegraphics-okular? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: calligra-words: requires kdegraphics-okular

Thanks!

Nierro commented on 2014-10-20 18:57

It seems that kdoctools is required as makedep!