Package Details: okular-git 21.07.70_r9334.g195bbe363-1

Git Clone URL: https://aur.archlinux.org/okular-git.git (read-only, click to copy)
Package Base: okular-git
Description: Document Viewer
Upstream URL: https://kde.org/applications/graphics/okular/
Keywords: kde kf5
Licenses: GPL, LGPL, FDL
Groups: kde-applications-git, kde-graphics-git
Conflicts: okular
Provides: okular
Submitter: Sevenseven
Maintainer: SolarAquarion (IslandC0der)
Last Packager: IslandC0der
Votes: 42
Popularity: 0.004233
First Submitted: 2011-07-11 05:22
Last Updated: 2021-05-30 18:01

Dependencies (27)

Required by (13)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

sl1pkn07 commented on 2016-01-08 17:26

https://quickgit.kde.org/?p=okular.git&a=commit&h=2f9246ae42ce6276002641ac02d9c6b880bcf7a3

no more kdelibs4support :D

edit: but fail build :/

fclad commented on 2015-12-19 00:14

There is a missing dependency. You can choose between extra/libkexiv2_4 or aur/libkexiv2-git.

sl1pkn07 commented on 2015-11-22 15:22

missing libkexiv2 (make/optdepend) (?)

pallegro commented on 2015-10-24 17:59

err, without the .orig

pallegro commented on 2015-10-24 17:59

Hopefully fixed upstream soon but for now this fixed the build for me ...

patch ${srcdir}/okular/generators/poppler/generator_pdf.cpp.orig <<EOF
285c285,291
< movie->setPlayMode( playbackLoops ? Okular::Movie::PlayRepeat : Okular::Movie::PlayOnce );
---
> //movie->setPlayMode( playbackLoops ? Okular::Movie::PlayRepeat : Okular::Movie::PlayOnce );
> if ( playbackLoops ) {
> movie->setPlayMode( Okular::Movie::PlayRepeat );
> } else {
> movie->setPlayMode( Okular::Movie::PlayLimited );
> movie->setPlayRepetitions( 1 );
> }
EOF

flying-sheep commented on 2015-09-03 12:10

hi, i get this runtime/compile error when trying to print/compiling

/usr/lib/libQt5PrintSupport.so.5.5.0: undefined reference to `_Z13q'

desaparecido commented on 2015-06-07 10:44

@FadeMind when you have a *-git package, if you build it, you'll have the last commit, so is in your care to have an updated package, except surely if the're a problem with the PKGBUILD so the maintainer will take care about it. I have the r7043.c2fc019 like you say without problems.

FadeMind commented on 2015-06-07 10:32

Please upgrade version to: r7043.c2fc019

andre.vmatos commented on 2015-05-04 14:06

Current version is segfaulting upon launch.
I've already rebuilt it completely, after last updates from gcc and glibc, and it's still segfaulting. Same with kwalletmanager-git. Backtrack of okular launch, without debug symbols:

(gdb) bt
#0 0x00007ffff51e6aec in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#1 0x00007ffff54db732 in QGuiApplication::screenAdded(QScreen*) () from /usr/lib/libQt5Gui.so.5
#2 0x00007ffff54d22e0 in QPlatformIntegration::screenAdded(QPlatformScreen*) () from /usr/lib/libQt5Gui.so.5
#3 0x00007fffe550873f in ?? () from /usr/lib/qt/plugins/platforms/libqxcb.so
#4 0x00007fffe5508f6b in ?? () from /usr/lib/qt/plugins/platforms/libqxcb.so
#5 0x00007fffe550c8a4 in ?? () from /usr/lib/qt/plugins/platforms/libqxcb.so
#6 0x00007fffe55214ab in ?? () from /usr/lib/qt/plugins/platforms/libqxcb.so
#7 0x00007ffff54d3012 in QPlatformIntegrationFactory::create(QString const&, QStringList const&, int&, char**, QString const&) () from /usr/lib/libQt5Gui.so.5
#8 0x00007ffff54debcb in QGuiApplicationPrivate::createPlatformIntegration() () from /usr/lib/libQt5Gui.so.5
#9 0x00007ffff54dfa1d in QGuiApplicationPrivate::createEventDispatcher() () from /usr/lib/libQt5Gui.so.5
#10 0x00007ffff51bae5f in QCoreApplication::init() () from /usr/lib/libQt5Core.so.5
#11 0x00007ffff51baec6 in QCoreApplication::QCoreApplication(QCoreApplicationPrivate&) () from /usr/lib/libQt5Core.so.5
#12 0x00007ffff54e1d99 in QGuiApplication::QGuiApplication(QGuiApplicationPrivate&) () from /usr/lib/libQt5Gui.so.5
#13 0x00007ffff5aa020d in QApplication::QApplication(int&, char**, int) () from /usr/lib/libQt5Widgets.so.5
#14 0x000000000040ccf4 in main ()

sl1pkn07 commented on 2015-01-30 14:41

qca fix fixed in git

greetings