Package Details: okular-git 21.07.70_r9334.g195bbe363-1

Git Clone URL: https://aur.archlinux.org/okular-git.git (read-only, click to copy)
Package Base: okular-git
Description: Document Viewer
Upstream URL: https://kde.org/applications/graphics/okular/
Keywords: kde kf5
Licenses: GPL, LGPL, FDL
Groups: kde-applications-git, kde-graphics-git
Conflicts: okular
Provides: okular
Submitter: Sevenseven
Maintainer: SolarAquarion (IslandC0der)
Last Packager: IslandC0der
Votes: 42
Popularity: 0.004373
First Submitted: 2011-07-11 05:22
Last Updated: 2021-05-30 18:01

Dependencies (27)

Required by (13)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

desaparecido commented on 2016-09-25 12:14

@student975 that one is the latest commit in framework branch (at end august) so is normal, to confirm when new commit update

https://quickgit.kde.org/?p=okular.git&a=shortlog&h=bfa28f1f64bfb8225db29d3f90c561b6e0603842

student975 commented on 2016-09-25 11:15

On _every_ update I get this reabuild:

aur/okular-frameworks-git r7376.bfa28f1f-1 -> r7376.bfa28f1-1

You see versions are always different. Typo?

nwah1 commented on 2016-08-21 16:14

kdelibs4support is no longer a dependency

https://github.com/KDE/okular/commit/ff274fdecc9d872ba8a58ed57cc29c36c30b1e89

FadeMind commented on 2016-05-23 14:35

Please add at the end of package () section

echo "NoDisplay=true" >> ${pkgdir}/usr/share/applications/org.kde.mobile.okular.desktop

This hide org.kde.mobile.okular.desktop file in Launcher App Menu.

Archange commented on 2016-05-23 14:04

New dependency needed: kdesignerplugin.

goetzc commented on 2016-03-21 18:03

Hi, I get this:

-- The following OPTIONAL packages have not been found:

* Qt5TextToSpeech
* LibSpectre (required version >= 0.2)
* QMobipocket

With both optdeps installed.
For QMobipocket I guess a frameworks port of kdegraphics-mobipocket is missing.

pallegro commented on 2016-02-13 10:38

its a bug introduced in commit 1b2de0d1d074769005db01b8de47e26c7e310057
(https://git.reviewboard.kde.org/r/126192/)
you need to remove the use of QUrl::StrictMode in shell/shell.cpp
here's a patch: http://pastebin.com/H5EgxDSb

stas.kazmin commented on 2016-02-08 20:36

Hello, have updated the package to the current version today. Now okular cannot open pdfs when there are spaces in the path. I then can open them from okulars open dialog without any problems. The error I get is:
QCommandLineParser: option not defined: "raise"
Could it be some missing dependency or is it a bug in the current okular version?

Thanks

daimonion commented on 2016-02-04 10:37

@sl1pkn07: revert this commit and you'll be okay:
https://github.com/KDE/okular/commit/4930045ff1534b6d192d36786c0747f69107e1e7

sl1pkn07 commented on 2016-01-31 09:34

-- Checking for module 'poppler-qt5'
-- Found poppler-qt5, version 0.39.0
-- snip --
-- The following RECOMMENDED packages have not been found:

* Poppler-Qt5 (required version >= 0.12.1) , A PDF rendering library , <http://poppler.freedesktop.org>
Support for PDF files in okular.