Package Details: okular-git 21.07.70_r9334.g195bbe363-1

Git Clone URL: https://aur.archlinux.org/okular-git.git (read-only, click to copy)
Package Base: okular-git
Description: Document Viewer
Upstream URL: https://kde.org/applications/graphics/okular/
Keywords: kde kf5
Licenses: GPL, LGPL, FDL
Groups: kde-applications-git, kde-graphics-git
Conflicts: okular
Provides: okular
Submitter: Sevenseven
Maintainer: SolarAquarion (IslandC0der)
Last Packager: IslandC0der
Votes: 43
Popularity: 0.43
First Submitted: 2011-07-11 05:22
Last Updated: 2021-05-30 18:01

Dependencies (27)

Required by (12)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Martchus commented on 2016-11-04 16:01

Here is an updated version based on okular-frameworks-git: https://github.com/Martchus/PKGBUILDs/blob/master/okular/git/PKGBUILD

desaparecido commented on 2016-11-03 23:14

frameworks branch was deleted ... now in master :-)

goetzc commented on 2016-10-10 17:12

@arojas that made it, thanks!

arojas commented on 2016-10-10 14:38

@goetzc rm -r src/build

goetzc commented on 2016-10-10 13:55

I get thisc maybe since qtchooser was removed:

==> Starting build()...
CMake Warning at /usr/share/ECM/modules/ECMQueryQmake.cmake:29 (message):
Failed call: /usr/lib/qt/bin/qmake -query "QT_INSTALL_PLUGINS"
Call Stack (most recent call first):
/usr/share/ECM/kde-modules/KDEInstallDirs.cmake:454 (query_qmake)
CMakeLists.txt:18 (include)

...

-- Configuring incomplete, errors occurred!
==> ERROR: A failure occurred in build().

arojas commented on 2016-10-07 20:12

@ArchangeGabriel thanks, updated

Archange commented on 2016-10-07 16:43

@arojas LIB_INSTALL_DIR has been deprecated in favor of KDE_INSTALL_LIBDIR. But I bet you know. ;)

student975 commented on 2016-09-25 16:23

@arojas Do you mean forcing .gitconfig to avoid != 7 length for all users is the correct way? I guess substring using is more defensive and friendly, isn't it? :)

arojas commented on 2016-09-25 15:31

git rev-parse --short should output 7 digits by default, unless you have changed that in your local git configuration

student975 commented on 2016-09-25 15:13

The last commit is bfa28f1 dated at 2016-08-31. I have firstly install the package just yesterday, and on _every_ update the package wants to be updated. How do you see the version are almost similar, but different? Compare it:

r7376.bfa28f1f-1
r7376.bfa28f1-1

I guess it is a typo or some kind of clash between

pkgver=r7376.bfa28f1

and

pkgver() {
...
}

Am I wrong?