Package Details: octoprint-venv 1.3.11-1

Git Clone URL: https://aur.archlinux.org/octoprint-venv.git (read-only)
Package Base: octoprint-venv
Description: The snappy snappy web interface for your 3D printer! (virtualenv installation type)
Upstream URL: http://octoprint.org/
Licenses: AGPL3
Conflicts: octoprint
Provides: octoprint
Submitter: Jake
Maintainer: Jake
Last Packager: Jake
Votes: 18
Popularity: 0.024283
First Submitted: 2017-01-15 12:46
Last Updated: 2019-05-27 09:48

Pinned Comments

Jake commented on 2017-10-24 16:03

If the hashsum is incorrect please just flag it out of date (also when there is no real new release, but the changed the old archive for some reason).

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Niklas commented on 2017-12-05 18:44

Fixed, seems like the source archive changed. The one I had from when I made the last update was still matching with the old sum. Weird.

Noeljunior commented on 2017-12-05 18:34

The sha512sum for the git source "https://github.com/foosel/OctoPrint/archive/1.3.5.tar.gz" does not match.

Jake commented on 2017-10-24 16:03

If the hashsum is incorrect please just flag it out of date (also when there is no real new release, but the changed the old archive for some reason).

Jake commented on 2017-10-24 16:02

Yes, they change released archives sometimes slightly and then the hash gets different. Thanks.

bmd_online commented on 2017-10-23 21:22

Need to update PKGBUILD, according to release 1.3.5 :

pkgver=1.3.5
pkgrel=1
sha256sums=('efd848382ad4004d6d0c1759e048a7ca4e5af85230a4ed36a23213637e919acc'
'7f7aa02075901d7501a03bda082f050ba5862e58034f0216b5a76d2a25135d3a')

Niklas commented on 2017-10-22 14:31

working on the update, can take a while since I have to remake the patches

midgard commented on 2017-08-14 15:16

Done (almost exactly 1 year ago): https://wiki.archlinux.org/index.php?title=Arch_packaging_standards&diff=446832&oldid=446829
It's a basic bash requirement btw.

Niklas commented on 2017-08-14 14:13

someone should put that in the Arch wiki then

midgard commented on 2017-08-13 15:49

Hi, in PKGBUILD you should quote variables that may contain spaces, in particular ${srcdir} and ${pkgdir}. Otherwise the build fails when there are directories that contain spaces. (Learn more at https://unix.stackexchange.com/a/131767)

Have a nice day.

Niklas commented on 2017-08-12 17:15

Finally updated to 1.3.4. Used some commits from the master branch to make 1.3.4 compatible with the newest versions of the Flask plugins and Tornado 4.5. If you are experiencing issues related to Tornado, you can try the python2-tornado-4.4 package instead (https://aur.archlinux.org/packages/python-tornado-4.4/) since 4.4 is the officially supported version of Tornado, however I did not have any problems with 4.5 so it should be fine.