Package Details: octopi 0.9.0-4

Git Clone URL: https://aur.archlinux.org/octopi.git (read-only, click to copy)
Package Base: octopi
Description: A powerful Pacman frontend using Qt libs
Upstream URL: http://octopiproject.wordpress.com
Licenses: GPL2
Conflicts: octopi-git, octopi-kde-git
Provides: octopi-kde-git
Submitter: ImNtReal
Maintainer: matmoul
Last Packager: matmoul
Votes: 355
Popularity: 46.21
First Submitted: 2013-09-03 23:42
Last Updated: 2019-10-24 18:21

Dependencies (12)

Required by (1)

Sources (5)

Pinned Comments

kikadf commented on 2018-06-10 06:04

Default build octopi-notifier without knotifications support. To enable edit PKGBUILD, uncomment #USE_NOTIFIER='1'

Latest Comments

1 2 3 4 5 6 ... Next › Last »

matmoul commented on 2019-11-01 23:30

it's sure that you need to update alpm_octopi_utils.

Normally if you use trizen or yay with the -Syu parameters, it works by itself.

If you have removed octopi, the best way is to remove alpm_octopi_utils and reinstall octopi...

lewis2e commented on 2019-11-01 16:21

Comment from @Jannis3005 worked for me. Was getting the same error as everyone else before building and installing alpm_octopi_utils

guru42 commented on 2019-10-25 19:20

Same error here:

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libalpm_octopi_utils.so: undefined reference to `alpm_sync_newversion'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libalpm_octopi_utils.so: undefined reference to `alpm_option_set_deltaratio'

collect2: Fehler: ld gab 1 als Ende-Status zurück make: *** [Makefile:446: bin/octopi] Fehler 1

The package needs to be updated?

kinoe commented on 2019-10-24 19:13

Reinstalling alpm_octopi_utils again (i had rebuilt it minutes before you updated it) did it for me. Thanks for help and keep up the great work!

matmoul commented on 2019-10-24 18:45

I've updated alpm_octopi_utils and bumped the octopi release, now octopi work again !!! Thanks to aarnt !!!

@kinoe I've tested with trizen and yay on a clean install with succes, your issue seem linked to your alpm_octopi_utils lib. Try to reinstall it.

kinoe commented on 2019-10-24 18:32

Thanks for octopi 0.9.0-4 but building (with yay) still aborts with errors:

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libalpm_octopi_utils.so: undefined reference to `alpm_sync_newversion'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../lib/libalpm_octopi_utils.so: undefined reference to `alpm_option_set_deltaratio'

e8hffff commented on 2019-10-24 14:02

octopi: symbol lookup error: /usr/lib/libalpm_octopi_utils.so: undefined symbol: alpm_option_set_deltaratio Seems to be caused by pacman build. So called pacman-next fixes this symbol availability.

Jannis3005 commented on 2019-10-24 09:37

Go to https://github.com/aarnt/alpm_octopi_utils and clone it, make the package and install. after that octopi should build fine

domker commented on 2019-10-23 19:39

@matmoul

@kinoe @Morganamilo The same error. (and collect2: error: ld returned 1 exit status make: *** [Makefile:464: bin/octopi] Error 1 )

kinoe commented on 2019-10-23 17:05

@Morganamilo rebuilt octopi 3 times with the helpers yay, pacaur, yaourt results in 'octopi: error while loading shared libraries: libalpm.so.11'--- building octopi-git shows the same error.