Package Details: octopi-git 1:0.8.1.r1166.144c3f2-1

Git Clone URL: https://aur.archlinux.org/octopi-git.git (read-only, click to copy)
Package Base: octopi-git
Description: A powerful Pacman frontend using Qt5 libs
Upstream URL: https://github.com/aarnt/octopi
Keywords: octopi
Licenses: GPL2
Conflicts: octopi, octopi-cachecleaner, octopi-notifier, octopi-pacmanhelper, octopi-repoeditor, oktopi-git
Provides: octopi, octopi-cachecleaner, octopi-notifier, octopi-pacmanhelper, octopi-repoeditor
Submitter: mrbit
Maintainer: kendfinger
Last Packager: SharkEzz
Votes: 72
Popularity: 0.073395
First Submitted: 2013-03-27 11:04
Last Updated: 2018-01-21 14:31

Dependencies (20)

Required by (2)

Sources (6)

Pinned Comments

SharkEzz commented on 2018-01-21 13:12

New update ! Fixed dependencies (added qtermwidget) To install this package, you will need to download "alpm_octopi_utils" from AUR in order to install octopi. Grab it here : https://aur.archlinux.org/packages/alpm_octopi_utils/

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

mrbit commented on 2015-01-28 19:31

dmoebius :)

dmoebius commented on 2015-01-28 15:00

It works now. Thanks, mrbit! :)

mrbit commented on 2015-01-27 11:50

ok, test please. :)

dmoebius commented on 2015-01-27 10:48

I can confirm the problems reported by p-we. Could you please fix it?
Furthermore, namcap reports the following problems:

octopi-git W: File (lib/octopi/) exists in a non-standard directory.
octopi-git W: File (lib/octopi/pacmanhelper) exists in a non-standard directory.
octopi-git E: Dependency qt4 detected and not included (libraries ['usr/lib/libQtDBus.so.4', 'usr/lib/libQtCore.so.4'] needed in files ['lib/octopi/pacmanhelper'])
octopi-git W: Dependency qt5-base included but already satisfied

p-we commented on 2015-01-02 22:20

Package has errors with pacman 4.2. Fix:
1) Comment out md5sums
2) Install #services to /usr/lib

mrbit commented on 2014-11-04 22:57

ok thanks, argymeg, done :)

argymeg commented on 2014-11-04 22:46

My bad, it doesn't work at all without qt5-declarative. You should probably add it to depends.

argymeg commented on 2014-11-04 22:38

True; however, with just qt5-base, building still fails:
==> Starting build...
Cloning into 'octopi-build'...
done.
Project ERROR: Unknown module(s) in QT: quickwidgets quick

I solved it by installing qt5-declarative. You should probably add it to makedepends.

mrbit commented on 2014-11-03 07:17

Hi, argymeg, yes now work with the QT5

argymeg commented on 2014-11-03 01:26

Afraid it doesn't build for me since the last update. At first it fails with a very not-intuitive error about not finding qmake; apparently qtchooser picks Qt5 by default, even though I don't have it installed, so I have to force Qt4 first ('export QT_SELECT=4'). Even then, however, build fails after a while (http://pastebin.archlinux.fr/651966).