Package Details: octopi-git 0.9.0.r336.a05add1-4

Git Clone URL: https://aur.archlinux.org/octopi-git.git (read-only, click to copy)
Package Base: octopi-git
Description: This is Octopi, a powerful Pacman frontend using Qt libs
Upstream URL: https://github.com/aarnt/octopi
Keywords: octopi pacman yaourt yay
Licenses: GPL2
Conflicts: octopi, octopi-cachecleaner, octopi-dev, octopi-helper, octopi-kde-git, octopi-notifier, octopi-notifier-frameworks, octopi-notifier-noknotify, octopi-notifier-qt5, octopi-repoeditor, octopi-sudo
Provides: octopi, octopi-cachecleaner, octopi-helper, octopi-notifier, octopi-repoeditor, octopi-sudo
Submitter: mrbit
Maintainer: class101
Last Packager: class101
Votes: 74
Popularity: 1.04
First Submitted: 2013-03-27 11:04
Last Updated: 2020-01-28 20:23

Pinned Comments

class101 commented on 2020-01-28 18:25

v0.9.0.r332 brings proxy support, thank you @aarnt ! [2250904|e846990]

  • PKGBUILD updated to match a closer version to the official one provided on github
  • PKGBUILD WITH_KNOTIFICATION=1 -> Enable the Plasma/knotifications support notifier
  • PKGBUILD WITH_DARK_ICON=0 -> Replace grey icon for dark theme support by the original green icon
  • PKGBUILD -j removed, if you need parallel build, set MAKEFLAGS in /etc/makepkg.conf
  • PKGBUILD qt5-tools added as makedeps (a new requirement to build octopi-sudo)
  • I didn't feel it was necessary to keep the old numix icons but if you want them back just let me know

Latest Comments

1 2 3 4 Next › Last »

class101 commented on 2020-01-28 18:25

v0.9.0.r332 brings proxy support, thank you @aarnt ! [2250904|e846990]

  • PKGBUILD updated to match a closer version to the official one provided on github
  • PKGBUILD WITH_KNOTIFICATION=1 -> Enable the Plasma/knotifications support notifier
  • PKGBUILD WITH_DARK_ICON=0 -> Replace grey icon for dark theme support by the original green icon
  • PKGBUILD -j removed, if you need parallel build, set MAKEFLAGS in /etc/makepkg.conf
  • PKGBUILD qt5-tools added as makedeps (a new requirement to build octopi-sudo)
  • I didn't feel it was necessary to keep the old numix icons but if you want them back just let me know

Morganamilo commented on 2019-11-24 05:57

Please don't set -j in the pkgbuild. That's just bad practise..

DonHugo commented on 2019-07-08 04:36

The package does currently not build (e.g. pacmanhelper has been removed, a new sudo module added). Please see https://github.com/aarnt/octopi/blob/master/PKGBUILD for the updated dependencies and build instructions.

SharkEzz commented on 2018-01-21 13:12

New update ! Fixed dependencies (added qtermwidget) To install this package, you will need to download "alpm_octopi_utils" from AUR in order to install octopi. Grab it here : https://aur.archlinux.org/packages/alpm_octopi_utils/

Fincer commented on 2017-12-21 21:15

Please add dependency qtermwidget, as of this commit: https://github.com/aarnt/octopi/commit/e08f7a8815c1a935912a05b02cb93bb007ab3860

Otherwise, compilation fails.

hotice commented on 2017-02-04 14:25

Looks like auto-hide ability for tray indicator (KDE Plasma) is not there anymore. Any specific reason the Auto visibility in KDE system tray settings not working?

DH4 commented on 2016-11-28 06:31

Just adopted this package and fixed several issues. Successfully building on x86_64, unable to test i686.

aurox commented on 2016-04-04 13:10

Dear nikmil

in PKGBUILD, line 65

_jc=$((${cpucount:-1}))

it should read _cpucount instead

LeonardK commented on 2015-05-17 13:33

Can you please use a more meaningful pkgver() please? This would make it more easy to check whether rebuilding makes sense by comparing with the release-versions.

(eg: git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
this would result as time of writing in:
0.7.0.r2.gb9d40be)

notuxius commented on 2015-04-09 06:35

PKGBUILD: line 49: qmake: command not found