Package Details: ocropy 1.0-2

Git Clone URL: https://aur.archlinux.org/ocropy.git (read-only, click to copy)
Package Base: ocropy
Description: Python-based OCR package using recurrent neural networks (formerly ocropus)
Upstream URL: https://github.com/tmbdev/ocropy
Licenses: Apache
Submitter: None
Maintainer: stativ
Last Packager: stativ
Votes: 63
Popularity: 0.000000
First Submitted: 2010-10-26 22:46
Last Updated: 2018-03-25 16:18

Latest Comments

1 2 3 4 Next › Last »

cmsigler commented on 2020-09-09 12:44

Hi, all,

Here's an updated patch which changes a depend from python-imaging to python2-imaging (due to recent changes in python2-pillow with some confusion related to the now deleted package python2-pillow6). With this, ocropy-1.3.3-2 should build (it WFM :^):

https://pastebin.com/EnGK6Ypq

HTH :^)

Clemmitt Sigler

cmsigler commented on 2020-06-01 16:29

Hi, all,

Patch to bring PKGBUILD up to ver. 1.3.3-1 and fix issues, md5sum and dead URLs:

https://pastebin.com/7cziWAJ5

NOTE: To get python2-scipy to build from AUR, that PKGBUILD also needs patching:

https://pastebin.com/mqCVp5RK

This WFM. HTH :^)

Clemmitt Sigler

grunix commented on 2020-01-24 15:11

Package can't be installed any longer because of missing dependency:

==> Error: Could not find all required packages: python2-pytables (Wanted by: ocropy)

dreieck commented on 2019-01-30 14:25

Checksum mismatch:

==> Validating source files with md5sums...
    ocropy-1.0.tar.gz ... Passed
    fixcast.patch ... FAILED
    en-default.pyrnn.gz ... Passed
==> ERROR: One or more files did not pass the validity check!

jorona commented on 2018-11-17 14:35

This package fails build. the md5 hash for fixcast.patch should be 83dd971f4ae6c6e6b02a71c2afc8fee0.

haawda commented on 2017-10-28 19:22

Please rename the downloaded tarball to something like $pkgname-$pkgver.tar.gz using the :: syntax, i.e. $pkgname-$pkgver.tar.gz::https://github.com/tmbdev/ocropy/archive/v1.0.tar.gz. Otherwise setting the SRCDEST in makepkg.conf can lead to probels hard to debug.

hemant_ng commented on 2016-03-06 04:56

New link works fine. Thanks.

stativ commented on 2016-02-24 18:59

Link fixed

hemant_ng commented on 2016-02-24 07:19

I got Not Found error from URL https://github.com/dblN/ocropy/commit/0e54bae2ef640a163c107a16b425dfd5ac698622.patch


==> Building and installing package
==> Making package: ocropy 1.0-2 (Wed Feb 24 12:42:53 IST 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading v1.0.tar.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 119 0 119 0 0 112 0 --:--:-- 0:00:01 --:--:-- 112
100 16.5M 0 16.5M 0 0 1521k 0 --:--:-- 0:00:11 --:--:-- 1827k
-> Downloading fixcast.patch...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0
curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading https://github.com/dblN/ocropy/commit/0e54bae2ef640a163c107a16b425dfd5ac698622.patch
Aborting...
==> ERROR: Makepkg was unable to build ocropy.
==> Restart building ocropy ? [y/N]
==> -------------------------------
==>

stativ commented on 2015-12-23 10:46

osalas: thank you, everything should be fixed now.