Package Details: oci-cli 3.0.5-1

Git Clone URL: https://aur.archlinux.org/oci-cli.git (read-only, click to copy)
Package Base: oci-cli
Description: Command line interface for Oracle Cloud Infrastructure
Upstream URL: https://github.com/oracle/oci-cli
Licenses: Apache
Submitter: meanjollies
Maintainer: meanjollies
Last Packager: meanjollies
Votes: 3
Popularity: 0.73
First Submitted: 2018-07-01 18:08
Last Updated: 2021-09-16 20:55

Latest Comments

Cirelli94 commented on 2021-01-02 17:42

Thanks. I rebooted, reinstalled and the dependency problem it's solved.

meanjollies commented on 2020-12-31 16:06

@Cirelli94, you need to have the python-oci package installed as a dependency.

Cirelli94 commented on 2020-12-31 15:02

Hi! Is someone having a problem like:

$ oci -v
Traceback (most recent call last):
  File "/usr/bin/oci", line 33, in <module>
    sys.exit(load_entry_point('oci-cli==2.17.0', 'console_scripts', 'oci')())
  File "/usr/bin/oci", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 972, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/oci_cli/__init__.py", line 11, in <module>
    from oci import fips
ModuleNotFoundError: No module named 'oci'

Thanks to the mantainer @meanjollies !