Package Details: ocamlnet 4.1.7-1

Git Clone URL: https://aur.archlinux.org/ocamlnet.git (read-only, click to copy)
Package Base: ocamlnet
Description: A library for Web and Internet programming in OCaml
Upstream URL: http://projects.camlcity.org/projects/ocamlnet.html
Licenses: GPL, LGPL
Submitter: guital
Maintainer: oriba
Last Packager: oriba
Votes: 58
Popularity: 0.22
First Submitted: 2008-07-23 20:32
Last Updated: 2020-06-05 12:58

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

tomatopeel commented on 2017-10-28 10:37

Looks like I just needed to replace my system's ncurses with ncurses-full(-git)

tomatopeel commented on 2017-10-28 10:07

I'm getting:

Checking endianess... /usr/bin/ld: /usr/lib/ocaml/libcamlrun.a(terminfo.o): undefined reference to symbol 'tgetnum'
/usr/lib/libtinfo.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
File "t.ml", line 1:
Error: Error while building custom runtime system
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build ocamlnet.

radek_r commented on 2017-09-30 12:16

Please add achitecture "armv7h" to the PKGBUILD.

mcgyver commented on 2017-08-16 11:37

[SOLVED]

Problem resolved removing the entire ocaml installation including all libraries and the base ocaml package, and reinstalled everything from scratch.
I wonder if there is a quicker solution than this, or if this is the only method by which ocaml updates works...

Thanks for your support!

mcgyver commented on 2017-08-16 10:53

@oriba Thanks for the suggestion: I already tried to update the ocaml-pcre package as well as all the other ocamlnet dependencies, and I am stuck.
Thank you for pointing this out, I understand I have bothered you, and I'll try to use other channels to ask questions.
Or, perhaps, I just remove this package...

All the best.
Regards

For completeness:

% pacman -Qo /usr/lib/ocaml/pervasives.cmi
/usr/lib/ocaml/pervasives.cmi is owned by ocaml 4.05.0-1
% pacman -Qo /usr/lib/ocaml/pcre/pcre.cmi
/usr/lib/ocaml/pcre/pcre.cmi is owned by ocaml-pcre 7.2.3-2

oriba commented on 2017-08-11 15:27

Please, questions that focus on non-package specific questions, please ask in OCaml-mailinglist.

Errors like
"Error: The files /usr/lib/ocaml/pervasives.cmi
and /usr/lib/ocaml/pcre/pcre.cmi make inconsistent assumptions
over interface Pervasives"
are typical problems that occur, when new OCaml is out and used libs are not recompiled. They are NOT specific to this package.
And: they are beginners-questions.

So, please ask such questions on ocaml-beginners mailinglist, or #ocaml at freenode, or stackoverflow.

Thanks.

oriba commented on 2017-08-11 14:16

@mcgyver: you need to update all dependencies of ocamlnet too.
This means: first update ocaml-pcre package it seems to be compiled with old ocaml-version.

mcgyver commented on 2017-08-11 13:55

Hi Everyone,

I have a problem updating this package, but I am not sure I understand what's wrong.
I have a clean Arch system, I installed this some time ago as dependency of google-drive-ocamlfuse but now if I try to update it, half way through the compilation process I receive the error:

[...]
make[1]: Entering directory '/home/sergio/build-repos/ocamlnet/src/ocamlnet-4.1.3/src/netstring-pcre'
opts="-opaque"; \
if [ -f "$(basename netstring_pcre.mli .ml)".nopaque ]; then opts=""; fi; \
ocamlfind ocamlc -g -safe-string -package "bytes unix bytes pcre" -w -25 -c $opts netstring_pcre.mli
File "netstring_pcre.mli", line 1:
Error: The files /usr/lib/ocaml/pervasives.cmi
and /usr/lib/ocaml/pcre/pcre.cmi make inconsistent assumptions
over interface Pervasives
make[1]: *** [../../Makefile.rules:116: netstring_pcre.cmi] Error 2
make[1]: Leaving directory '/home/sergio/build-repos/ocamlnet/src/ocamlnet-4.1.3/src/netstring-pcre'
make: *** [Makefile:23: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

Could anyone help me decoding it, and what to do to solve this?
I already tried to update and recompile ocaml-pcre, and it worked without any issue.
Suggestions welcome.
Thank you!

oriba commented on 2017-08-07 15:17

@isra17: thanks for reporting this. I forgot to remove the commands that use the netsys_posix.ml. Update is comming soon.

isra17 commented on 2017-08-07 14:16

Package is broken, last update removed (>24h) the netsys_posix.ml file that is still used in the PKGBUILD.

pwd: /tmp/pkg/src/ocamlnet-4.1.3
ls -l ../.. => total 4452
-rw-r--r-- 1 isra users 4553037 Aug 7 10:10 ocamlnet-4.1.3.tar.gz
d--x--x--x 2 isra users 40 Aug 7 10:10 pkg
-rw-r--r-- 1 isra users 1848 Aug 7 10:09 PKGBUILD
drwxr-xr-x 3 isra users 80 Aug 7 10:10 src
cp: cannot stat '../../netsys_posix.ml': No such file or directory