Package Details: ocamlfuse 2.7.1-10

Git Clone URL: https://aur.archlinux.org/ocamlfuse.git (read-only, click to copy)
Package Base: ocamlfuse
Description: An ocaml binding for fuse.
Upstream URL: https://github.com/astrada/ocamlfuse/
Licenses: GPL2
Submitter: WhyNotHugo
Maintainer: pricechrispy
Last Packager: pricechrispy
Votes: 28
Popularity: 0.000042
First Submitted: 2013-08-20 05:04
Last Updated: 2020-06-26 20:32

Latest Comments

1 2 3 4 5 Next › Last »

lantw44 commented on 2020-06-26 08:20

Please don't use master.zip as the source. The PKGBUILD should specify a tag or a commit hash, or it is going to break every time the upstream pushes a commit. You can use git+https:// as the source to clone the git repository directly instead of downloading zip from GitHub.

PPlatypus commented on 2020-06-25 17:39

Checksum fails when building:

:: Parsing SRCINFO (1/1): ocamlfuse
==> Making package: ocamlfuse 2.7.1-9 (Thu 25 Jun 2020 11:30:29 AM)
==> Retrieving sources...
  -> Found master.zip
==> Validating source files with sha256sums...
    master.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!

presidentwolf commented on 2020-06-24 20:50

Should be resolved now in source. The issue was that ocamlfuse was dependent on at most dune 2.5.0 because it included one of its (now private) APIs. Astrada has now fixed that in main.

presidentwolf commented on 2020-06-19 19:43

Ok, I'm guessing that something is terribly broken here. I followed linkjay's instructions for this to build using cvs5. The package builds - but can't be used by google-drive-ocamlfuse. Dune can't find it, so I'm guessing we need to use the dune install step.

I tried using your opam install recommendations, but all of those packages are already installed.

matejdro commented on 2020-06-17 12:50

Checksum check fails when building:

Building ocamlfuse...
==> Making package: ocamlfuse 2.7.1-8 (sre 17 jun 2020 14:49:08)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found master.zip
==> Validating source files with sha256sums...
    master.zip ... FAILED
==> ERROR: One or more files did not pass the validity check!
Failed to build ocamlfuse

linkjay commented on 2020-06-16 08:50

I have found that running opam install dune-configurator sexplib0 within the cloned directory for this project or any other dune/ocaml project can fix build issues. If you are having an issue with dune.configurator not being found, find your cloned directory, and run that command.

For example, I am installing this package through yay so I can attempt to install it first, then let it fail. Afterwards, I can cd to ~/.cache/yay/ocamlfuse/src/ocamlfuse-master and execute opam install dune dune-configurator and the such. A few other ocaml packages will fail too, and you can just cd into those cloned src directories and install what dune is requiring. It's very hacky, but it can work to get a successful install of these packages. After installing the opam deps, you can simply install the package again with yay or yaourt, and be sure not to clear your cache before it successfully installs!

linkjay commented on 2020-06-16 08:23

@presidentwolf The Stdune error can be fixed by installing dune through opam opam install dune

@Doctor_Propain The camlidl error can be fixed by installing this through opam opam install camlidl

It throw an error and ask you to initialize opam first or something, you should just do that and run the install command again. Should work, however you will run into the stopping issue which is that dune.configurator is not found.

Do this within each of the cached, cloned build dirs. You can also run opam install dune-configurator.

linkjay commented on 2020-06-16 08:17

Not really sure what happened with this project. I hope that the maintainer updates the PKGBUILD here. I have found a workaround to get it working which is to use the version v2.7.1_cvs5 from 2017 to get this package to work. Simply do the following:

  1. Clone the PKGBUILD here: git clone https://aur.archlinux.org/ocamlfuse.git
  2. Cd into the dir: cd ocamlfuse
  3. Download the old, desired version of this project from GitHub (https://github.com/astrada/ocamlfuse/archive/v2.7.1_cvs5.zip): wget https://github.com/astrada/ocamlfuse/archive/v2.7.1_cvs5.zip (this is necessary so we can get a sha256sum from it)
  4. Unzip the archive: unzip v2.7.1_cvs5.zip
  5. Get the sha256sum of the file so we can use it in this PKGBUILD: sha256sum v2.7.1_cvs5.zip (I got 9325118d6e7998816ba3dcc72c1a62198aa27612ecc82d021ad093558769f185)
  6. Edit PKGBUILD with the following changes:

    • Source from https://github.com/astrada/ocamlfuse/archive/master.zip to https://github.com/astrada/ocamlfuse/archive/v2.7.1_cvs5.zip
    • Insert new sha256sum into the sha256sums field

    • In build() function do the following: - Change cd "$srcdir/$pkgname-master" to cd ocamlfuse-2.7.1_cvs5 - Uncomment cd lib and the make command - Comment the dune comment

    • In package() function do the following: - Change cd "$srcdir/$pkgname-master" to cd ocamlfuse-2.7.1_cvs5 - Uncomment both export commands, install command, and make command - Comment mkdir commands and the dune command

    • Run makepkg -si within the directory. Should compile just fine.

Author needs to update this package to either support this version again, or fix whatever problems are occuring with dune. I had an issue with the key because the author setup the sha256sum to work off of an old master sha256sum, and it has since been updated so now the new master archive is invalid. This needs to be fixed. Once you update the sha256sum, dune seems to have some compiling issues that can be fixed by installing dune and other required libraries (specified in the error messages) through opam. Seems to be that the unfixable error after that is this:

$ makepkg -si
==> Making package: ocamlfuse 2.7.1-8 (Tue Jun 16 01:15:53 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found master.zip
==> Validating source files with sha256sums...
    master.zip ... Passed
==> Extracting sources...
  -> Extracting master.zip with bsdtar
==> Starting build()...
File "lib/config/dune", line 3, characters 12-29:
3 |  (libraries dune.configurator))
                ^^^^^^^^^^^^^^^^^
Error: Library "dune.configurator" not found.
Hint: try: dune external-lib-deps --missing @install
==> ERROR: A failure occurred in build().
    Aborting...

presidentwolf commented on 2020-06-13 12:32

Doesn't build anymore.

==> Starting build()...
File "lib/config/discover.ml", line 1, characters 6-12:
1 | open! Stdune
      ^^^^^^
Error: Unbound module Stdune
==> ERROR: A failure occurred in build().
    Aborting...

Doctor_Propain commented on 2020-05-18 04:38

I'm having some trouble installing this package via the standard way of makepkg. The error messages during build are:

==> Starting build()...
File "lib/dune", line 4, characters 34-41:
4 |  (libraries unix threads bigarray camlidl)
                                      ^^^^^^^
Error: Library "camlidl" not found.
Hint: try: dune external-lib-deps --missing @install
File "lib/config/dune", line 3, characters 12-29:
3 |  (libraries dune.configurator))
                ^^^^^^^^^^^^^^^^^
Error: Library "dune.configurator" not found.
Hint: try: dune external-lib-deps --missing @install
==> ERROR: A failure occurred in build().
    Aborting...

camlidl is installed on the system, so I am confused why it is not being found by the build process. dune-configurator is not installed, nor is it listed as a dependency for this package.