Package Details: ocaml-ppx_deriving_yojson-git 20200812-1

Git Clone URL: https://aur.archlinux.org/ocaml-ppx_deriving_yojson-git.git (read-only, click to copy)
Package Base: ocaml-ppx_deriving_yojson-git
Description: A Yojson codec generator for OCaml >= 4.02.
Upstream URL: https://github.com/ocaml-ppx/ppx_deriving_yojson
Licenses: MIT
Provides: ocaml-ppx_deriving_yojson
Submitter: soimort
Maintainer: soimort (crave)
Last Packager: soimort
Votes: 0
Popularity: 0.000000
First Submitted: 2018-05-18 22:24
Last Updated: 2020-09-20 21:09

Required by (4)

  • fstar (requires ocaml-ppx_deriving_yojson) (make)
  • fstar-git (requires ocaml-ppx_deriving_yojson) (make)
  • kremlin (requires ocaml-ppx_deriving_yojson)
  • ocaml-fstar (requires ocaml-ppx_deriving_yojson) (make)

Sources (1)

Latest Comments

soimort commented on 2020-09-20 21:17

@Score_Under Yes. In the recent version of ppx_deriving_yojson they replaced ppxfind with ppxlib: https://github.com/ocaml-ppx/ppx_deriving_yojson/commit/5b3d744861564694f37a4a702ca1e6f237ac9b95#diff-457f044ded09d14d120a0145217aab21

So I've just added it to makedeps. Can you try the latest PKGBUILD? If it still fails on the dune build step, then there might be some dependency issue with ocaml-ppxlib (unfortunately I'm not sure if this can be fixed on my side)

Score_Under commented on 2020-09-20 16:21

I may have run into the same problem. I upgraded everything (including ocaml) and ran into all sorts of other build issues including failure to build ocaml-ppx_deriving.

However, it seems like I've managed to recover things by rebuilding all the AUR ocaml packages as well as manually rebuilding dune and ocaml-findlib (which don't seem to have been updated for the new version of ocaml, and there are sticky issues with ocaml-findlib that I have hacked around without much knowledge on the actual topic).

Things have "recovered" to the point that they're about the same as my last post, including the same error message. Unfortunately, it's the dune build step that fails, so I'm not really sure what to do about it. I don't know very much about ocaml (though I am tempted to learn).

This failure aside, do you think it's necessary to add ocaml-ppxlib to the makedeps?

soimort commented on 2020-09-20 14:29

@Score_Under Could you try replacing the line (in PKGBUILD)

  dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind -printconf destdir)"

with

  DESTDIR="$pkgdir" dune install --prefix '/usr' --libdir 'lib/ocaml'

and see if it works? I can't verify it myself at the moment since building ocaml-ppxlib fails for me.

Score_Under commented on 2020-09-15 14:18

Build fails for me:

File "src/dune", line 13, characters 18-33:
13 |  (preprocess (pps ppxlib.metaquot))
                       ^^^^^^^^^^^^^^^
Error: Library "ppxlib.metaquot" not found.
Hint: try:
  dune external-lib-deps --missing @@default
Done: 32/56 (jobs: 1)==> ERROR: A failure occurred in build().
    Aborting...

After installing ocaml-ppxlib from the AUR, it fails on:

File "src/ppx_deriving_yojson.ml", line 1, characters 5-11:
1 | open Ppxlib
         ^^^^^^
Error: Unbound module Ppxlib
Done: 43/58 (jobs: 1)==> ERROR: A failure occurred in build().
    Aborting...