Package Details: ocaml-migrate-parsetree 1.7.3-2

Git Clone URL: https://aur.archlinux.org/ocaml-migrate-parsetree.git (read-only, click to copy)
Package Base: ocaml-migrate-parsetree
Description: Convert OCaml parsetrees between different major versions
Upstream URL: https://github.com/ocaml-ppx/ocaml-migrate-parsetree
Keywords: convert library ocaml parsetrees version versions
Licenses: custom:LGPL2.1 with linking exception
Submitter: J5lx
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 0
Popularity: 0.000000
First Submitted: 2017-08-01 16:04
Last Updated: 2020-05-18 18:24

Pinned Comments

dpeukert commented on 2020-04-09 22:13

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/master/ocaml-migrate-parsetree

Latest Comments

kureta commented on 2020-04-16 12:08

thanks @dpeukert that solved the issue.

dpeukert commented on 2020-04-15 13:56

@kureta This is caused by an update of ocaml causing the code compiled with the previus version to no longer be compatible with the newly compiled code. I've bumped the pkgrel of all my affected packages, but it looks like your ocaml-ppx_derivers wasn't updated. Reinstalling ocaml-ppx_derivers (and any other packages ocaml complains about not being consistent) should fix this.

kureta commented on 2020-04-13 22:03

Hi! I am getting this error while trying to update this package

$ (cd _build/default && /usr/bin/ocamlopt.opt -w -40 -linkall -g -o test/driver/null/ppx.exe -I /usr/lib/ocaml/compiler-libs -I /usr/lib/ocaml/ppx_derivers -I /usr/lib/ocaml/result -I src -I test/driver/ppx1 -I test/driver/ppx2 /usr/lib/ocaml/compiler-libs/ocamlcommon.cmxa /usr/lib/ocaml/result/result.cmxa /usr/lib/ocaml/ppx_derivers/ppx_derivers.cmxa src/migrate_parsetree.cmxa test/driver/ppx1/ppx1.cmxa test/driver/ppx2/ppx2.cmxa test/driver/null/.ppx.eobjs/native/ppx.cmx)
File "_none_", line 1:
Error: Files /usr/lib/ocaml/ppx_derivers/ppx_derivers.cmxa
       and /usr/lib/ocaml/stdlib.cmxa
       make inconsistent assumptions over implementation Stdlib__printf

dpeukert commented on 2020-04-09 22:13

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/master/ocaml-migrate-parsetree

oriba commented on 2020-01-12 02:01

There seems to be a fix... https://bugs.archlinux.org/task/57200

J5lx commented on 2018-02-05 13:24

Please note that updating this package is currently (as of 2018-02-05) impossible due to bug FS#57200.