Package Details: ocaml-lwt 4.3.0-1

Git Clone URL: (read-only, click to copy)
Package Base: ocaml-lwt
Description: A library for cooperative threads in OCaml
Upstream URL:
Licenses: MIT
Submitter: SerP
Maintainer: J5lx
Last Packager: J5lx
Votes: 14
Popularity: 0.000000
First Submitted: 2010-07-22 14:30
Last Updated: 2019-09-11 12:41

Latest Comments

1 2 3 Next › Last »

J5lx commented on 2018-02-05 13:33

Please note that it’s currently (as of 2018-02-05) impossible to update this package as the new version depends on ocaml-migrate-parsetree which can’t be built due to bug FS#57200.

J5lx commented on 2017-03-13 06:25

Looks like a missing dependency… though I have no idea how it slipped in. I’ll take a closer look at it this afternoon.

kaptoxic commented on 2017-03-13 03:29

For some reason I get this strange error:
==> Starting build()...
ocamlfind: Package `result' not found
W: Field 'pkg_result' is not set: Command ''/usr/bin/ocamlfind' query -format %d result > '/tmp/oasis-ff9362.txt'' terminated with error code 2
E: Cannot find findlib package result
E: Failure("1 configuration error")
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build ocaml-lwt.

Any ideas?

J5lx commented on 2015-05-13 13:34

I added it to the configure line. Thanks for the notice!

talex commented on 2015-05-13 10:03

I think this package should now be compiled with --enable-camlp4 too (needed since 2.4.4). See:

cormac-obrien commented on 2014-11-12 22:22

Not 100% sure, but this package appears to be out of date.

E: Cannot find findlib package camlp4
E: Cannot find findlib package camlp4.extend
E: Cannot find findlib package camlp4.quotations.o
E: Failure("3 configuration errors")
==> ERROR: A failure occurred in build().

I have ocaml-findlib and camlp4 installed from the official repos.

talex commented on 2014-05-24 11:10

Lwt 2.4.4 (and 2.4.5) have now been released, which should fix these problems:

bcdarwin commented on 2014-02-02 04:55

Ocaml-lwt < 2.4.4 won't build with ocaml >= 4.01, so this package should add 'ocaml <= 4.00' to `depends`. This will be resolved when 2.4.4 is released.

In the meantime, I've released an ocaml-lwt-git package providing ocaml-lwt.

someoneelse123 commented on 2014-01-22 11:27

Build fails on my machine:

ftrvxmtrx commented on 2012-10-05 13:34

Thanks, fixed.
Updated to 2.4.2 as well.