Package Details: ocaml-lsp-git r484.d57bd91-1

Git Clone URL: https://aur.archlinux.org/ocaml-lsp-git.git (read-only, click to copy)
Package Base: ocaml-lsp-git
Description: OCaml Language Server Protocol implementation
Upstream URL: https://github.com/ocaml/ocaml-lsp
Keywords: lsp ocaml
Licenses: ISC
Conflicts: ocaml-lsp
Provides: ocaml-lsp
Submitter: condy
Maintainer: condy (dctxmei)
Last Packager: condy
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-24 14:17
Last Updated: 2020-03-22 07:38

Latest Comments

condy commented on 2020-09-28 18:19

@SkyrisBactera Thanks for reporting.

3 additional packages are required: ocaml-octavius, ocaml-ppx_expect and csexp. Saddly csexp is not on AUR and installing ocaml-ppx_expect failed on my machine. Needs investigation...

git-reset ocaml-lsp-git to c4e668d (4 mon ago) if you're in urgency.

SkyrisBactera commented on 2020-09-27 20:51

Building the package fails, seemingly to missing dependencies:

File "vendor/stdune/dune", line 11, characters 30-35:
11 |  (libraries stdlib-shims unix csexp)
                                   ^^^^^
Error: Library "csexp" not found.
Hint: try:
  dune external-lib-deps --missing @@default
File "vendor/stdune/dune", line 4, characters 16-25:
4 |  (action (run %{bin:cppo} -V OCAML:%{ocaml_version} %{ml} -o %{targets})))
                    ^^^^^^^^^
Error: Program cppo not found in the tree or in PATH
 (context: default)
File "lsp/test/dune", line 64, characters 7-17:
64 |   (pps ppx_expect)))
            ^^^^^^^^^^
Error: Library "ppx_expect" not found.
Hint: try:
  dune external-lib-deps --missing @@default
      menhir lsp/bin/typescript/ts_parser.{ml,mli}

condy commented on 2020-03-22 07:08

@kapheine

Thanks!

I also emailed the dune maintainer a month ago, but he said

I’m no longer the maintainer of dune in Arch Linux since July last year. You can see this information here: https://www.archlinux.org/packages/community/x86_64/dune/.

I’m adding the current maintainer in copy.

sob

kapheine commented on 2020-03-22 07:02

This package seems to now have a dependency on ocaml-menhir.

It also requires dune >= 2.0.0 now. I've emailed the maintainer regarding updating the package, but it can also manually be rebuilt by just bumping the version:

pkgver=2.4.0
8ba200e35c4494d1468d37dfff84b30d1e3f2899cd4122f465d3636674ae8827