Package Details: ocaml-lame-git r85.5ed5784-1

Git Clone URL: https://aur.archlinux.org/ocaml-lame-git.git (read-only, click to copy)
Package Base: ocaml-lame-git
Description: OCaml bindings to the LAME mp3 encoder
Upstream URL: https://github.com/savonet/ocaml-lame
Licenses: GPL2
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 0
Popularity: 0.000000
First Submitted: 2019-12-14 23:30
Last Updated: 2020-10-18 17:51

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

SmashedSqwurl commented on 2020-10-16 15:53

Here's a patch to get the PKGBUILD working with dune:

diff --git a/PKGBUILD b/PKGBUILD
index 44740ae..b8cc079 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,16 +18,14 @@ pkgver() {

 build() {
     cd "${srcdir}/${pkgname}"
-    ./bootstrap
-    ./configure
-    make
+    dune build
 }

 package() {
     cd "${srcdir}/${pkgname}"
+    dune install --prefix "${pkgdir}/usr" --libdir "${pkgdir}$(ocamlfind printconf destdir)"

-    export OCAMLFIND_DESTDIR="${pkgdir}$(ocamlfind printconf destdir)"
-    mkdir -p "${OCAMLFIND_DESTDIR}/stublibs"
-    make install
+    # Remove docs
+    rm -rf "${pkgdir}/usr/doc"
 }
 md5sums=('SKIP')

toaru_yousei commented on 2020-07-29 22:59

+1 for @brolin comment.

brolin commented on 2020-06-09 17:50

It is necessary to update the PKGBUILD to build the package using dune.

Thanks