Package Details: ocaml-base 0.14.1-1

Git Clone URL: https://aur.archlinux.org/ocaml-base.git (read-only, click to copy)
Package Base: ocaml-base
Description: Full standard library replacement for OCaml
Upstream URL: https://github.com/janestreet/base
Keywords: base function library ocaml replacement standard
Licenses: MIT
Submitter: J5lx
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 11
Popularity: 0.000012
First Submitted: 2018-06-27 19:45
Last Updated: 2021-01-16 13:47

Pinned Comments

dpeukert commented on 2020-04-09 22:09

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/main/ocaml-base

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

ogghi commented on 2019-11-03 12:39

File "compiler-stdlib/gen/gen.ml", line 59, characters 33-51: 59 | let toc = (input_value ic : Cmo_format.library) in ^^^^^^^^^^^^^^^^^^ Error: Unbound module Cmo_format ==> ERROR: A failure occurred in build(). Aborting... Error making: ocaml-base

This is what I get, to be more precise...

ogghi commented on 2019-11-03 11:51

Hi, I was trying to install google-drive-ocamlfuse and stumbled upon this problem...any fix coming?

J5lx commented on 2019-11-01 18:52

It's a downstream fix (i. e. on the Arch side rather than the OCaml side), but on the ocaml-compiler-libs package, not on this one. I've been meaning to make a bug report about it but I haven't gotten around to it yet since I'm kinda busy atm. I'm currently planning to do it this weekend.

nixit commented on 2019-11-01 13:07

@J5lx, is the fix for ocaml-compiler-libs an upstream fix or a local fix to the package in the AUR?

nixit commented on 2019-10-20 18:57

@J5lx

Thanx for the explanation, makes perfect sense!

J5lx commented on 2019-10-20 11:30

Just re-download the PKGBUILD of this package by using the link in the “Package Actions” box at the top of the page or by running git clone <https://aur.archlinux.org/ocaml-base.git> (but without angle brackets, those are incorrectly inserted by the AUR software). (But just to make sure we're on the same page here, this is only about the deprecation warning posted by ubgen (“The jbuilder binary is deprecated and will cease to be maintained in July 2019. Please switch to dune instead.”), which you asked about. You will still not be able to build the package until ocaml-compiler-libs gets fixed as described in my last post. Those are two separate issues.)

nixit commented on 2019-10-19 19:04

@J5lx, any ideas on how I can get rid of the old version and try again? I thought I completely purged everything with the -Rsn. any tips are appreciated.

J5lx commented on 2019-10-17 21:30

@MokkeMeguru is right, the cause of the problem is a packaging issue in ocaml-compiler-libs (which, unfortunately, is nothing new). OCaml 4.09 made some changes to its directory structure but the installation routine in ocaml-compiler-libs wasn’t adjusted accordingly when the package was updated. I’ll try to make a bug report soon™.

@nixit: It’s on the maintainer, and I already made that change a while ago. If you still get warnings about it, you’re most likely using an old version.

jdegreef commented on 2019-10-17 20:31

@MokkeMeguru That doesn't work, after your instructions ocamlfuse cannot be compiled because of a camlidl problem. See my solution ;) https://aur.archlinux.org/packages/google-drive-ocamlfuse/#comment-712227

nixit commented on 2019-10-16 15:34

@ubgen,

Is switching to dune on the package maintainer, or the one installing (me)?