Package Details: obs-studio-git 21.0.2.r0.g6ed55995-1

Git Clone URL: https://aur.archlinux.org/obs-studio-git.git (read-only)
Package Base: obs-studio-git
Description: Free and open source software for video recording and live streaming.
Upstream URL: https://github.com/jp9000/obs-studio
Keywords: obs-studio
Licenses: GPL2
Conflicts: obs-studio
Provides: obs-studio=21.0.2.r0.g6ed55995
Submitter: ledti
Maintainer: benklett
Last Packager: benklett
Votes: 74
Popularity: 0.759533
First Submitted: 2014-03-12 22:29
Last Updated: 2018-02-27 14:53

Required by (16)

Sources (2)

Pinned Comments

Joir2000 commented on 2019-05-17 15:33

Note : If you want to stream with ssl, for example to stream to facebook, you'll have to install mbedtls first.

benklett commented on 2016-02-06 23:11

This is a -git package, that means you have to update it!
Please do not flag it out of date because of the version number.
The version number will automatically increase to the version of the latest commit.

If you want to have the stable versions, please install the package obs-studio from [community].

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

escondida commented on 2015-12-22 01:15

Hey, thanks for packaging this! Just a couple quick things: you can simplify your dependencies by not listing deps that are already required by other deps, and you don't need to list base or base-devel packages, such as curl, in your deps at all. You can also simplify a number of things by using the literal string obs-studio instead of $_pkgname (after all, the name isn't really a variable), and every PKGBUILD function starts you out already in $srcdir. Finally, the user can specify their own MAKEFLAGS (-j2 et al.) in /etc/makepkg.conf.

If you're interested, there's a simplified PKGBUILD at https://ptpb.pw/ASmJ

benklett commented on 2015-09-28 17:11

If you use an AUR-Helper and you want to install the newest versions of the package, when they come out, please use the obs-studio package.
This package here will always install the newest git version, the version number will automatically increment itself. Please do not flag it out of date, because it does not show the newest version.

benklett commented on 2015-09-25 18:48

ArcticVanguard, i did not mean you, it was anthrit. I took over maintainership, as there was the move to aur4. If you ever want to improve the package, you can. I added you to the list of co-maintainers.

ArcticVanguard commented on 2015-09-25 18:42

I didn't flag it out of date, as far as I'm aware somebody else did. I don't know why, it works fine. I've been busy with life atm and I don't currently have a working Arch system which is why I haven't gotten around to removing the flag or anything. The package is fine.

benklett commented on 2015-09-25 15:18

Does the package not build anymore or why did you flag it out of date?

masteryod commented on 2015-07-21 18:03

error: Failed to create OpenGL context.

Apparently OBS require OpenGL 3.2

https://obsproject.com/forum/threads/failed-to-create-opengl-context-on-ubuntu-14-04.25286/

masteryod commented on 2015-07-21 18:03

Apparently OBS require OpenGL 3.2

https://obsproject.com/forum/threads/failed-to-create-opengl-context-on-ubuntu-14-04.25286/

masteryod commented on 2015-07-21 18:02

Apparently OBS requires GPU with OpenGL 3.2 support

https://obsproject.com/forum/threads/failed-to-create-opengl-context-on-ubuntu-14-04.25286/

seo.disparate commented on 2015-06-03 19:35

I'm using gcc 5.1

I'm only using the -DUNIX_STRUCTURE=1 flag because it was mentioned on the obs github project in the building instructions for linux mentioned here https://github.com/jp9000/obs-studio/blob/master/INSTALL .

Maybe it's not necessary if it works for you without it?

ArcticVanguard commented on 2015-05-31 20:35

Sorry guys, I'm not able to reproduce the problems compiling. Everything's up to date on my system and I'm just using the basic pkgbuild. Can I get an idea of what version of gcc you all are running? I'm still on 4.9.2.