Package Details: obs-studio-git 27.0.0.rc1.r9.g38d17acdb-2

Git Clone URL: https://aur.archlinux.org/obs-studio-git.git (read-only, click to copy)
Package Base: obs-studio-git
Description: Free and open source software for video recording and live streaming.
Upstream URL: https://github.com/obsproject/obs-studio
Keywords: obs-studio
Licenses: GPL2
Conflicts: obs-studio
Provides: obs-studio=27.0.0.rc1.r9.g38d17acdb
Submitter: ledti
Maintainer: benklett
Last Packager: benklett
Votes: 90
Popularity: 2.74
First Submitted: 2014-03-12 22:29
Last Updated: 2021-04-05 10:53

Dependencies (34)

Required by (72)

Sources (5)

Pinned Comments

thotypous commented on 2021-02-05 14:12

If you don't want to build this package yourself, hourly builds are available at https://aur.chaotic.cx

benklett commented on 2016-02-06 23:11

This is a -git package, that means you have to update it!
Please do not flag it out of date because of the version number.
The version number will automatically increase to the version of the latest commit.

If you want to have the stable versions, please install the package obs-studio from [community].

haddadmj commented on 2014-07-22 00:55

i uninstall xfce4 & install kdebase and obs worked ;; but when it run pop-out this message :: error: Failed to initialize video: Unspecified error:

ledti commented on 2014-07-21 14:12

@haddadmj, try reinstalling qt5-base.

pacman -Ql qt5-base
...
qt5-base /usr/lib/qt/plugins/platforms/libqeglfs.so
qt5-base /usr/lib/qt/plugins/platforms/libqkms.so
qt5-base /usr/lib/qt/plugins/platforms/libqlinuxfb.so
qt5-base /usr/lib/qt/plugins/platforms/libqminimal.so
qt5-base /usr/lib/qt/plugins/platforms/libqminimalegl.so
qt5-base /usr/lib/qt/plugins/platforms/libqoffscreen.so
qt5-base /usr/lib/qt/plugins/platforms/libqxcb.so <-
...

haddadmj commented on 2014-07-21 13:36

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, kms, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

arch xfce4

useless2764 commented on 2014-07-20 00:32

well, pretty useless for me till it can actually see my 2 separate x screens, but it does compile and work otherwise

ledti commented on 2014-07-16 11:40

@Weegee, Actually, it makes sense to prefer system libraries over static ones. I'll update the package in a bit to add jansson and add a few optional dependencies that I noticed, too.

Thanks for reporting.

ledti commented on 2014-07-16 11:12

@Weegee, I'm not sure why that's happening. I don't have jansson installed and can compile just fine. I could be the odd one out, but there hasn't been anyone else who has reported this, so for now I'm not going to add jansson as a build dependency. That might be worth asking about upstream if you're sure you're using all the right packages.

If anyone else has same issue let me know and I'll add jansson as a build dependency.

Weegee commented on 2014-07-16 09:00

Hey, I dropped the obs-git package as you've submitted your PKGBUILD earlier. However I get the following error when building obs-studio-git if I don't have jansson installed (i. e. OBS uses its own jansson version):

https://paste.archlinux.de/G4u/

Jocce commented on 2014-07-15 20:27

Yeh i forgot to remove the comment, but i fixed it by reinstalling FFMpeg

ledti commented on 2014-07-15 20:09

Are you using ffmpeg from the extra repository?

'pacman -Qs x265 && pacman -Qs ffmpeg'

Jocce commented on 2014-07-15 15:51

Only me who get:

/usr/bin/ld: warning: libx265.so.21, needed by /usr/lib/libavcodec.so.55, not found (try using -rpath or -rpath-link)
/usr/lib/libavcodec.so.55: undefined reference to `x265_param_parse'
/usr/lib/libavcodec.so.55: undefined reference to `x265_param_default_preset'
/usr/lib/libavcodec.so.55: undefined reference to `x265_param_free'
/usr/lib/libavcodec.so.55: undefined reference to `x265_max_bit_depth'
/usr/lib/libavcodec.so.55: undefined reference to `x265_encoder_open_21'
/usr/lib/libavcodec.so.55: undefined reference to `x265_encoder_headers'
/usr/lib/libavcodec.so.55: undefined reference to `x265_param_alloc'
/usr/lib/libavcodec.so.55: undefined reference to `x265_picture_init'
/usr/lib/libavcodec.so.55: undefined reference to `x265_encoder_encode'
/usr/lib/libavcodec.so.55: undefined reference to `x265_encoder_close'
collect2: error: ld returned 1 exit status
obs/CMakeFiles/obs.dir/build.make:555: recipe for target 'obs/obs' failed
make[2]: *** [obs/obs] Error 1
CMakeFiles/Makefile2:261: recipe for target 'obs/CMakeFiles/obs.dir/all' failed
make[1]: *** [obs/CMakeFiles/obs.dir/all] Error 2
Makefile:137: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().

Anyone know a solution?