Package Details: obs-studio-git 21.0.2.r0.g6ed55995-1

Git Clone URL: (read-only)
Package Base: obs-studio-git
Description: Free and open source software for video recording and live streaming.
Upstream URL:
Keywords: obs-studio
Licenses: GPL2
Conflicts: obs-studio
Provides: obs-studio=21.0.2.r0.g6ed55995
Submitter: ledti
Maintainer: benklett
Last Packager: benklett
Votes: 74
Popularity: 0.759533
First Submitted: 2014-03-12 22:29
Last Updated: 2018-02-27 14:53

Required by (16)

Sources (2)

Pinned Comments

Joir2000 commented on 2019-05-17 15:33

Note : If you want to stream with ssl, for example to stream to facebook, you'll have to install mbedtls first.

benklett commented on 2016-02-06 23:11

This is a -git package, that means you have to update it!
Please do not flag it out of date because of the version number.
The version number will automatically increase to the version of the latest commit.

If you want to have the stable versions, please install the package obs-studio from [community].

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

benklett commented on 2018-01-23 20:02

HamishTPB, I added python and swig as dependencies.

I could not add lua support because it would not compile. ATM I do not have further information on why this is happening, but I will update the package when this is fixed.

HamishTPB commented on 2018-01-23 19:17

The new version of OBS studio has scripting support but this is not enabled in this build (spoke to OBS peeps and they said it has to be enabled explicitly). Can it be enabled, please?

benklett commented on 2018-01-12 17:58

Thank you for your comment copygirl,

I changed the PKGBUILD according to your comment. Please report if anything breaks.

copygirl commented on 2018-01-11 18:20

Trying to install this package along with obs-linuxbrowser gets me the error "obs-studio and obs-studio-git are in conflict.".

I asked around and this appears to be because obs-linuxbrowser requires obs-studio>=20.0.1 and this package only provides obs-studio, not obs-studio=$pkgver. Specifying the version for virtual provisions appears to be required. Alternatively, of course, one could remove the version requirement on the other package.

svanheulen commented on 2017-08-31 14:38

Thanks benklett, that does the trick. I'm going to try doing some upstream pull requests so that the ftl-sdk can be built as a separate package since that's what will be required for the community non-git package.

benklett commented on 2017-08-30 17:53

Thank you svanheulen,

I have updated the PKGBUILD to support the FTL plugin.
Could you have a look if this works for you?

svanheulen commented on 2017-08-30 17:19

They added support for's FTL protocol in version 20.0.x but the ftl-sdk that's needed to compile support for it is included as a submodule. I was able to add a "prepare" function to the PKGBUILD to update the submodules but I'm not sure if this is the best solution.

prepare() {
cd $pkgname
git submodule update --init --recursive

bazukas commented on 2017-03-29 12:58

Looks like vst-plugin is not available for linux yet. My bad.

benklett commented on 2017-03-26 18:42

bazukas, If I read the CMakeLists.txt file correctly, the vst plugin is only enabled if the OS is Windows or Mac.

bazukas commented on 2017-03-26 17:12

Obs installed using this aur misses the new VST plugin. I think this happens because it is supposed to be pulled from git submodule.