Package Details: oblige-git 1:7.70+15+gea6b33c-1

Git Clone URL: https://aur.archlinux.org/oblige-git.git (read-only, click to copy)
Package Base: oblige-git
Description: A random level maker for games based on the Doom engine (git version)
Upstream URL: http://oblige.sourceforge.net/
Licenses: GPL
Conflicts: oblige
Provides: oblige
Submitter: grubber
Maintainer: grubber
Last Packager: grubber
Votes: 2
Popularity: 0.000319
First Submitted: 2019-02-27 08:44
Last Updated: 2020-04-14 05:47

Latest Comments

thann commented on 2021-03-09 20:00

I think ill make a new package called "oblige-obsidian" for dashodangers fork

vikits commented on 2021-02-01 02:56

There is a more recent repo for this at https://github.com/dashodanger/Oblige. This compiles fine and has some improvements. Can you update to this one?

deathtrip commented on 2021-01-19 19:28

You should also include the patch to look for addons in the install directory. Without it obaddon won't work out of the box. https://github.com/caligari87/Oblige/pull/6

thann commented on 2020-04-07 11:45

If you edit the PKGBUILD and change make to make "CXX=g++-8" it will work =]

Star-X commented on 2020-04-06 22:23

Won't build, get this when trying to install it.

gui/csg_clip.cc: In function ‘void DoWriteClip(dclipnode_t&, bool)’:

gui/csg_clip.cc:1057:32: error: cannot bind packed field ‘raw_clip.dclipnode_s::children[0]’ to ‘short unsigned int&’

1057 | std::swap(raw_clip.children[0], raw_clip.children[1]);

| ~~~~~~~~~~~~~~~~~~~^

make: *** [Makefile:107: obj_linux/csg_clip.o] Error 1

==> ERROR: A failure occurred in build().

Aborting...

Seems to be related to Quake for some unknown reason.