Package Details: nyaovim 0.2.0-1

Git Clone URL: https://aur.archlinux.org/nyaovim.git (read-only)
Package Base: nyaovim
Description: Neovim frontend built on Electron
Upstream URL: https://www.npmjs.com/package/nyaovim
Keywords: electron gui neovim
Licenses: MIT
Submitter: dywedir
Maintainer: fusion809
Last Packager: fusion809
Votes: 19
Popularity: 0.024697
First Submitted: 2016-01-22 15:43
Last Updated: 2018-01-28 05:49

Latest Comments

lucc commented on 2017-07-07 21:50

I assume "gconf" should be a runtime dependency. I didn't have it and nyaovim complained on startup.

fusion809 commented on 2016-07-22 00:43

@htfy96 implemented.

htfy96 commented on 2016-07-20 09:05

Hi,

adding '%F' in .desktop will allow user to launch this when opening files:

Exec=nyaovim %F
Keywords=text;editor;text editor;vim;neovim;

fusion809 commented on 2016-06-04 04:49

@admiralswan I just assumed responsibility for this package and implemented your suggestion in my first commit.

admiralswan commented on 2016-04-07 17:53

Hi,
Given that this is a GUI application, I think including a .desktop file in the install is appropriate. Something like this:

[Desktop Entry]
Name=Nyaovim
GenericName=Nyaovim
Comment=Web-enhanced Extensible Neovim Frontend
Exec=nyaovim
Icon=/usr/lib/node_modules/nyaovim/resources/icon/nyaovim-logo.png
Terminal=false
Type=Application
Categories=Development;

which would have an associated line in the PKGBUILD

install -D -m644 "nyaovim.desktop" "${pkgdir}/usr/share/applications/nyaovim.desktop"

kab3n commented on 2016-02-01 14:39

Hi,
thanks for providing this package. Am I right to guess libnotify should be added as a dependency.