Package Details: nvidia-xrun 0.3-0

Git Clone URL: https://aur.archlinux.org/nvidia-xrun.git (read-only)
Package Base: nvidia-xrun
Description: Script to run dedicated X server with discrete nvidia graphics
Upstream URL: https://github.com/Witko/nvidia-xrun
Licenses: GPL
Submitter: Witko
Maintainer: Witko
Last Packager: Witko
Votes: 33
Popularity: 1.739245
First Submitted: 2015-06-10 20:36
Last Updated: 2016-10-20 21:48

Latest Comments

« First ‹ Previous 1 2 3

aradan_d commented on 2016-01-08 19:15

Sorry, I just ran again yaourt -S nvidia-xrun and now it installs ok. Must have changed an environment variable or something. I deleted my post. I will delete this one in the future too.

Witko commented on 2016-01-08 08:24

In which phase do you get this? I just installed it fine right now.

Isnt this happening while running? What do you run?

tedbell commented on 2015-12-30 01:18

When I try to run a game with wine
(nvidia-xrun wine <game>) I get a blank screen. I know this works because I tried it with glxspheres and got ten times the frame rate.

Witko commented on 2015-12-21 08:49

Hi Salsadoom,
the fix for you would be to uncomment the AllowEmptyInitialConfiguration in /etc/X11/nvidia-xorg.conf
For me it works as it is. Also i'd like to ask you to try it this way:
1) create dir /etc/X11/nvidia-xorg.conf.d
2) create there a file 10-nvidia-empty-conf.conf (name it your way :) )
3) put this into the file:
Section "Screen"
Identifier "nvidia"
Device "nvidia"
Option "AllowEmptyInitialConfiguration" "Yes"
# Option "UseDisplayDevice" "none"
EndSection
4) check whether it works

Im curious whether this will override the settings in nvidia-xorg.conf. This would be then the most desired way how to do config adjustments. I wanted to add such dir into the package itself but didnt want to spend too much time on it. So if it will work i will do so. Thank you!

salsadoom commented on 2015-12-20 20:30

Hey! Not yet :) But a lot closer, the xorg log shows a lot of different output, but doesn't quite start. I've pasted it here http://pastebin.com/93M48h7X maybe this makes a bit more sense to you. Cheers! Merry xmas to you to!

Witko commented on 2015-12-20 19:35

Hi, i believe i fixed the issue with no screens found. Please try it out. Sorry for delay.
Merry Christmas!

Witko commented on 2015-12-09 09:13

Hi, this was definetely working. Now it seems that after a change in X it does not. I will fix this(i hope) once i have some time. If you have any problem create an issue for it and i will try to take care of it. Thanks!

salsadoom commented on 2015-12-09 01:56

Does this work for anyone? I get no screens found on my system. It flips on the nvidia card, but just shoots out that error. Tried running it with X running (but from a proper console tty), and without, same error.

EDIT: driver loads ok too. Made sure the BusID was fine, it was.

Witko commented on 2015-11-26 22:18

Hi,
im sorry but nvidia-dkms conflicts with nvidia but does not provide it. So it means the dependency would have to be replaced. Try to ask the maintainer of nvidia-dkms to add provides field. If not possible I might create nvidia-xrun-dkms package. But I would strongly prefer the first solution(if applicable).

tsirif commented on 2015-11-26 21:06

Can you also include as a dependency the official repository's nvidia-dkms package? https://www.archlinux.org/packages/extra/x86_64/nvidia-dkms/