Package Details: nvidia-docker 2.2.2-1

Git Clone URL: https://aur.archlinux.org/nvidia-docker.git (read-only, click to copy)
Package Base: nvidia-docker
Description: Build and run Docker containers leveraging NVIDIA GPUs
Upstream URL: https://github.com/NVIDIA/nvidia-docker
Keywords: cuda docker gpu nvidia
Licenses: BSD
Submitter: marcelhuber
Maintainer: jshap (kiendang)
Last Packager: jshap
Votes: 34
Popularity: 0.21
First Submitted: 2016-07-26 09:17
Last Updated: 2019-09-09 17:21

Pinned Comments

jshap commented on 2019-08-17 01:14

This package is now deprecated in upstream, as you can now use nvidia-container-toolkit together with docker 19.03's new native GPU support in order to use NVIDIA accelerated docker containers without requiring nvidia-docker. I'm keeping the package alive for now because it still works but in the future it may become fully unsupported in upstream.

For more info, see: https://wiki.archlinux.org/index.php/Docker#Run_GPU_accelerated_Docker_containers_with_NVIDIA_GPUs

Latest Comments

« First ‹ Previous 1 2 3

xoryouyou commented on 2017-02-13 11:40

Newest version is https://github.com/NVIDIA/nvidia-docker/releases/tag/v1.0.0

changes needed to be made:

pkgver=1.0.0
source_x86_64=(https://github.com/NVIDIA/nvidia-docker/releases/download/v${pkgver}/nvidia-docker-${pkgver}-1.${arch}.rpm)
sha256sums_x86_64=('6669686952a190557ceccb272c97e9fc11f744d8e949e78c3a5854517a39e958')


tiagoshibata commented on 2016-10-02 14:21

Docker should be a dependency:

nvidia-docker run --name digits -d -p 5000:34448
nvidia-docker | 2016/10/02 11:16:02 Error: failed to run docker command