Package Details: nvidia-beta-dkms 455.28-1

Git Clone URL: https://aur.archlinux.org/nvidia-beta-dkms.git (read-only, click to copy)
Package Base: nvidia-beta-dkms
Description: NVIDIA driver sources for linux (beta version)
Upstream URL: https://www.nvidia.com/
Licenses: custom
Conflicts: nvidia
Provides: NVIDIA-MODULE, nvidia=455.28, nvidia-beta=455.28, nvidia-dkms=455.28
Submitter: alucryd
Maintainer: dbermond
Last Packager: dbermond
Votes: 44
Popularity: 0.42
First Submitted: 2013-03-12 11:21
Last Updated: 2020-10-08 17:46

Required by (36)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

Xaero252 commented on 2015-10-15 15:29

So is the new kernel module intended by loaded via modules-load.d or wrapped into the initramfs? I'll give it a go either way and I knew I was overlooking something obvious that's what I get for skimming patch notes.

Det commented on 2015-10-15 05:34

I changed the PKGBUILD internals quite a lot, because the previous pushd/eval/popd (x2) thing was just a mess:

- old: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=nvidia-beta-dkms&id=2ffc2341789ed6392a267d3f1023af6c742f79ae
- new: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=nvidia-beta-dkms

anish commented on 2015-10-15 04:07

Thanks Det !

Det commented on 2015-10-15 03:55

Should work now.

sanerb commented on 2015-10-15 03:38

lol, Det beat me to it. ;)

sanerb commented on 2015-10-15 03:38

yeah, seeing some issues on my end too.

this likely is related to this in the changelog:

"Added a new kernel module, nvidia-modeset.ko. This new driver component works in conjunction with the nvidia.ko kernel module to program the display engine of the GPU." (https://www.nvidia.com/download/driverResults.aspx/92712/en-us)

was getting some "FATAL: kernel module nvidia-modeset not found" or whatever the syntax is in the journal.

Det commented on 2015-10-15 03:37

Seems like you didn't include the new nvidia-modeset.ko?

Xaero252 commented on 2015-10-15 03:18

There appears to be an issue with EDID and metamode detection with this version of the nvidia drivers; I updated from the previous version of this package and had a non-working system; rolling back from these to those in the core repo has me up and running again but I typically run the beta drivers.

Relevant Xorg logs:
http://paste.ubuntu.com/12785789/
http://paste.ubuntu.com/12785793/

*Note: in the second paste I had manually defined my metamodes in my Xorg.conf for my second seat; this was an attempt to get things working on the current version of this package. This did not fix things.

anish commented on 2015-10-14 17:38

@juston-li This update fixes the 4.3 compatibility issues as well, bumping up to <4.4 now

Det commented on 2015-10-14 17:01

@anish, "Manage Co-Maintainers" in the "Package Actions" on the right. Third from bottom. I'd be _happy_ to add you in any of my packages you want.

@AnAkkk, yeeeah, but some don't, and makepkg alone surely doesn't, as opposed to just updating them in sync, separately.

E: Okay, even makepkg does with "--pkg <list>": https://www.archlinux.org/pacman/makepkg.8.html