Package Details: nteract-bin 0.14.4-1

Git Clone URL: https://aur.archlinux.org/nteract-bin.git (read-only)
Package Base: nteract-bin
Description: Interactive literate coding notebook
Upstream URL: https://nteract.io
Keywords: IDE
Licenses: BSD-3-Clause
Submitter: chendaniely
Maintainer: chendaniely (ConorIA)
Last Packager: ConorIA
Votes: 4
Popularity: 0.000000
First Submitted: 2016-10-11 19:41
Last Updated: 2019-07-16 11:30

Dependencies (14)

Required by (0)

Sources (2)

Latest Comments

ConorIA commented on 2018-02-14 00:14

Done, but forgot to bump pkgrel.

gerson commented on 2018-02-13 23:51

sha256sums needs update.

==> Validating source files with sha256sums... nteract_0.7.1_amd64.deb ... FAILED LICENSE ... Passed

ConorIA commented on 2018-02-09 23:55

Sorry, when I say common I mean common in the sense that it is included in https://www.archlinux.org/packages/core/any/licenses/. BSD3-Claude isn't. See here for reference: https://wiki.archlinux.org/index.php/PKGBUILD#license

The license that I'm using here is straight from the nteract GitHub repo. They had originally forgotten to change the project name on the license file, but have since fixed it, hence the change.

chendaniely commented on 2018-02-09 23:49

@ConorIA That was my confusion. Thought that the license didn't change so no checksum change was needed, saw the build failed so I just got rid of it.

The main gihub page says the license is "BSD 3-Clause "New" or "Revised" License" 1. This is a common license, where did you get the one used in this package?

ConorIA commented on 2018-02-09 23:09

The license used here isn't a common lucense and therefore must be included. Why remove it. The only thing that needed to change was the version number and checksum.

chendaniely commented on 2017-10-04 02:55

There's currently a bug in the new update. Please see this thread for details:

https://twitter.com/nteractio/status/915382264170659842

edit: v.0.3.1 fixes the issue

waka-waka commented on 2017-03-05 15:08

Hi, I couldn't get this package to run properly. So I just ran a debtap of the latest release https://github.com/nteract/nteract/releases/tag/v0.1.0
https://github.com/nteract/nteract/releases/download/v0.1.0/nteract_0.1.0_amd64.deb

Debtap built package with no issues and pacman installed it without hassles. Runs flawlessy.

Maybe it's a good idea to update this package with the debtap pkg?

chendaniely commented on 2016-10-11 19:53

Please see discussion here on the initial package:

https://github.com/nteract/nteract/issues/983