Package Details: non-daw-git 0.r1823.3946d39-1

Git Clone URL: https://aur.archlinux.org/non-daw-git.git (read-only, click to copy)
Package Base: non-daw-git
Description: A modular Digital Audio Workstation system - Git version.
Upstream URL: http://non.tuxfamily.org
Licenses: GPL
Groups: multimedia
Conflicts: non-daw, non-mixer, non-sequencer, non-session-manager, non-timeline
Provides: non-mixer, non-sequencer, non-session-manager, non-timeline
Submitter: epicurious
Maintainer: lievenmoors
Last Packager: lievenmoors
Votes: 22
Popularity: 0.006866
First Submitted: 2012-04-07 08:28
Last Updated: 2016-03-06 20:18

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Anonymous comment on 2013-06-28 12:53

This PKGBUILD isn't as good as it could be. Let me help:

Please use pacman's capability of handling git, look into the wiki to see how it works.

And after building a package (which you did before you uploaded it here, right?) please use the tool namcap to see possible problems.

Here's my correction of your package, feel free to use it how it is or as an inspiration
PKGBUILD http://codepad.org/h8tUp1G1
non-suite-git.install http://codepad.org/pjHKtYTH

jrdnjhntn commented on 2013-04-27 01:48

@Lievenmoors - Jonathon already knows (non-dev) but is not using gcc-4.8.0 nor is it available on his distro (for now).

when i can find some time, i will have a closer look and see if i can put together a bug report against gcc-4.8.0, although to be honest, this isn't the highest priority for me. (i have more important/critical projects to focus on right now).

lievenmoors commented on 2013-04-22 12:38

@ Ninez

Yes I do realize that, and I was going to do the same thing...
Maybe we should let each other know when one of us finds the time
to file a bug report...

greets

jrdnjhntn commented on 2013-04-22 12:29

@lievenmoors

no problem. but do realize this is a workaround to a current problem in gcc (most likely). When i have an hour or two, that i can focus on this bug - i will most likely be filing a bug report against gcc ~ but at least for now, this package can be compiled with -O2

cheerz.

lievenmoors commented on 2013-04-22 11:24

@ Ninez

Thank you so much for your help! I found out about the segfault a few days ago,
but didn't know -O2 would work around it. I updated the PKGBUILD to make
use of the pacman 4.1.0 VCS features as well.

thanks again...

jrdnjhntn commented on 2013-04-21 23:20

hey,

just a head's up ~ this package doesn't compile - because it fails with -O3 optimization level with gcc-4.8.0. (segfaults). Instead, you can use -O2 which will allow non-daw-git to compile okay.

cheerz

lievenmoors commented on 2013-03-10 16:16

Well, there is ntk-git which provides ntk.

Anonymous comment on 2013-03-09 10:56

Hi, the dependency ntk doesn't exist in the AUR or repos.

imv commented on 2012-12-09 18:15

Makedependency should be python, not waf, because waf script is included in the package.
Also, I've made a package ntk-git. You may consider adding it to dependencies. As far as I tried, building non against local ntk is not straightforward.

epicurious commented on 2012-12-02 06:34

Aware of flag - currently wrestling with yet another change in build method, and an extra makedependency [waf]. Close to solution, so possibly next few days.