Package Details: noisetorch-git 0.9.0.r5.ge7072b2-1

Git Clone URL: https://aur.archlinux.org/noisetorch-git.git (read-only, click to copy)
Package Base: noisetorch-git
Description: Real-time microphone noise suppression on Linux.
Upstream URL: https://github.com/lawl/NoiseTorch
Licenses: GPL3
Conflicts: noisetorch, noisetorch-bin
Provides: noisetorch
Submitter: erbrecht
Maintainer: erbrecht
Last Packager: erbrecht
Votes: 7
Popularity: 1.13
First Submitted: 2020-07-18 04:21
Last Updated: 2021-01-22 14:45

Latest Comments

1 2 3 Next › Last »

erbrecht commented on 2021-01-22 14:47

This is working again. Now that they are using their own implementation of the ladspa plugin, I was able to remove the dependency on noise-suppression-for-voice, and we no longer need the patches.

techge commented on 2021-01-20 11:23

With latest changes (https://github.com/lawl/NoiseTorch/commit/b747084bb0a033e10f55058b73b06238a666d8ae) the dependency of package noise-suppression-for-voice is no longer necessary as it is build-in the main package.

erbrecht commented on 2021-01-18 16:05

Thanks for the feedback. I'll be able to take a look at this tonight or tomorrow morning. Hopefully it's something I overlooked and we can get it working again.

NiklasM commented on 2021-01-18 15:58

Since the version 0.9.0.r5.ge7072b2 noisetorch doesn't work for me any more (But I am also a Manjaro [testing] user). If I load it on my microphone I always get a yellow warning Inconsistent state, please unload first. in the GUI. With downgrade I tested if previous installed versions (from 0.7.2.beta.r0.g02665f1 to 0.9.0.r3.g4f7ac32) did still work and all did. Is this a Manjaro specific bug (version of pulseaudio is 14.2) or does this also happen on Arch with the latest version 0.9.0.r5.ge7072b2?

I compared the logs (in the /tmp/ directory - https://gist.github.com/AnonymerNiklasistanonym/7a60bc422683cae61a5b6b32e18d4474) and in the latest version the biggest difference is after the line Loaded null sink as idx: 28 the next line says PulseAudio error: commandLoadModule -> Module initialization failed.

If it works on Arch you can see this issue as resolved for now - I'll just wait and check future versions while using the downgraded one that still works fine.

erbrecht commented on 2020-12-11 14:32

now depends on noise-suppression-for-voice (AUR) for the librnnoise_ladspa.so library. it was building the ladspa plugin from source previously, and embedding the .so file into the binary. should be more in line with packaging conventions/guidelines now.

new non-git release version coming soon!

erbrecht commented on 2020-12-08 20:03

take a look at my post

https://bbs.archlinux.org/viewtopic.php?pid=1942538

don't want to clutter this up with unrelated discussions. but any feedback in the forum is greatly appreciated!

Svenstaro commented on 2020-12-08 19:27

Sure, what do you need feedback on?

erbrecht commented on 2020-12-08 19:04

I've been looking at a plain 'noisetorch' package, but I'm going to need a little feedback first.

Svenstaro commented on 2020-11-16 20:00

Exactly. Such a package would also make a fine candidate for addition to [community].

erbrecht commented on 2020-11-16 19:32

So you'd like to see a 'noisetorch' package that builds from source, but builds from tagged releases instead of the master branch? Essentially the '-bin' version but built from source?