Package Details: nodejs-webpack 5.31.0-1

Git Clone URL: https://aur.archlinux.org/nodejs-webpack.git (read-only, click to copy)
Package Base: nodejs-webpack
Description: JavaScript bundler (CommonJs, AMD, ES6 modules, CSS, Images, JSON, CoffeeScript, LESS)
Upstream URL: https://webpack.js.org/
Licenses: MIT
Submitter: dseg
Maintainer: simon04
Last Packager: simon04
Votes: 20
Popularity: 1.41
First Submitted: 2015-02-12 14:04
Last Updated: 2021-04-09 07:32

Latest Comments

je-vv commented on 2021-04-10 01:25

Hi @simon04, is nodejs-webpack a superset of nodejs-webpack-cli now? They have files in conclict with recent update of both. Actually I had to uninstall both, to be able to install one of them, and only one. I just went for nodejs-webpack, since that's I'd guess the biggest one...

> pacman -S nodejs-webpack-cli
...
checking for file conflicts...
error: failed to commit transaction (conflicting files)
nodejs-webpack-cli: /usr/bin/webpack exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/LICENSE exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/README.md exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/SECURITY.md exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/bin/webpack.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/hot/dev-server.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/hot/emitter.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/hot/lazy-compilation-node.js exists in filesystem (owned by nodejs-webpack)
...
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/APIPlugin.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/AbstractMethodError.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/AsyncDependenciesBlock.js exists in filesystem (owned by nodejs-webpack)
...
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/webworker/ImportScriptsChunkLoadingPlugin.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/webworker/ImportScriptsChunkLoadingRuntimeModule.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/lib/webworker/WebWorkerTemplatePlugin.js exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/.bin/acorn exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/.bin/browserslist exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/.bin/terser exists in filesystem (owned by nodejs-webpack)
...
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/yocto-queue/license exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/yocto-queue/package.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/node_modules/yocto-queue/readme.md exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/package.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/schemas/WebpackOptions.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/schemas/_container.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/schemas/_sharing.json exists in filesystem (owned by nodejs-webpack)
...
nodejs-webpack-cli: /usr/lib/node_modules/webpack/schemas/plugins/sharing/ProvideSharedPlugin.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/schemas/plugins/sharing/SharePlugin.json exists in filesystem (owned by nodejs-webpack)
nodejs-webpack-cli: /usr/lib/node_modules/webpack/types.d.ts exists in filesystem (owned by nodejs-webpack)
Errors occurred, no packages were upgraded.

If one is a subset of the other, can the conflict variable be used to prevent such errors. Otherwise, can they be installed in a way they don't conflict with each other? Thanks !

je-vv commented on 2021-03-28 22:58

@simon04, could you please add --cache "${srcdir}/npm-cache" or something similar so that npm doesn't pollute the FS with bloated stuff? Thanks !

Plexcon commented on 2017-07-28 21:10

npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.1.2 (node_modules/webpack/node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.1.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

simon04 commented on 2017-04-03 09:26

Please update the description since many more modules/filetypes are supported:
> CommonJs, AMD, ES6 modules, CSS, Images, JSON, Coffeescript, LESS