Package Details: nodejs-web-ext 3.2.0-2

Git Clone URL: https://aur.archlinux.org/nodejs-web-ext.git (read-only)
Package Base: nodejs-web-ext
Description: A command line tool to help build, run, and test web extensions
Upstream URL: https://developer.mozilla.org/en-US/Add-ons/WebExtensions
Licenses: MPL2
Submitter: yan12125
Maintainer: yan12125 (lilac)
Last Packager: lilac
Votes: 6
Popularity: 0.000337
First Submitted: 2016-07-16 06:03
Last Updated: 2019-09-28 10:05

Latest Comments

yan12125 commented on 2019-09-19 00:51

Hi @Kalinda, I saw you opened an issue on GitHub. I think it's the right place - AFAIK running add-ons on Android is a relatively new feature, so it might not be quite stable.

Those build warnings should be harmless. I've seen them before.

Kalinda commented on 2019-09-18 18:58

Hello, I'm not sure if I should be asking this here or upstream since I don't know the source of the issue and it seems weird for it to have just started like this without being updated when it's been working just fine until now.

I am getting this error when I try and test my addon with Firefox for Android on my phone using adb and web-ext run:

FailError: Failure: '' at /usr/lib/node_modules/web-ext/node_modules/adbkit/lib/adb/parser.js:183:29 at tryCatcher (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/util.js:26:23) at Promise._settlePromiseFromHandler (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/promise.js:503:31) at Promise._settlePromiseAt (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/promise.js:577:18) at Async._drainQueue (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/async.js:128:12) at Async._drainQueues (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/async.js:133:10) at Immediate.Async.drainQueues [as _onImmediate] (/usr/lib/node_modules/web-ext/node_modules/bluebird/js/main/async.js:15:14) at runCallback (timers.js:705:18) at tryOnImmediate (timers.js:676:5) at processImmediate (timers.js:658:5)

I tried with another addon that I know works and it gives the same error. It does this on two different computers, both running Arch. All my packages are up to date. I decided to recompile web-ext just in case and I got these warnings:

yarn install v1.17.3 info No lockfile found. warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json. [1/5] Validating package.json... [2/5] Resolving packages... warning @cliqz-oss/firefox-client > js-select@0.6.0: Package no longer supported. Contact support@npmjs.com for more info. warning addons-linter > po2json > nomnom@1.8.1: Package no longer supported. Contact support@npmjs.com for more info. warning addons-linter > eslint-plugin-no-unsafe-innerhtml > eslint > file-entry-cache > flat-cache > circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor. warning require-uncached@2.0.0: Renamed to import-fresh. [3/5] Fetching packages... info fsevents@2.0.7: The platform "linux" is incompatible with this module. info "fsevents@2.0.7" is an optional dependency and failed compatibility check. Excluding it from installation. info fsevents@1.2.9: The platform "linux" is incompatible with this module. info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation. [4/5] Linking dependencies... warning " > eslint-plugin-flowtype@3.11.1" has incorrect peer dependency "eslint@>=6.0.0".

I don't remember if I got these the first time I compiled this, as it was a while ago.

Any help is much appreciated, although this is likely an upstream issue. Thanks!

yan12125 commented on 2018-09-06 14:31

@LA-MJ: thanks for the note! Instead of adding more workarounds for npm, I moved to packager-friendlier yarn.

LA-MJ commented on 2018-08-31 05:00

https://wiki.archlinux.org/index.php/Node.js_package_guidelines#Package_contains_reference_to_.24srcdir.2F.24pkgdir

yan12125 commented on 2018-03-31 17:07

@z3ntu: Thanks for the linked article! I did seen some permission issues before yet I haven't had time for investigation, not to say a solution. Now I've applied the suggested workaround.

z3ntu commented on 2018-03-31 12:46

You should add the chmod command found in https://wiki.archlinux.org/index.php/Node.js_package_guidelines to the PKGBUILD as the node_modules folder will have 777 permissions otherwise which is very bad.

yan12125 commented on 2017-06-25 11:41

Thanks @jtojnar! Updated.