Package Details: nodejs-nativefier 7.7.0-1

Git Clone URL: (read-only, click to copy)
Package Base: nodejs-nativefier
Description: Wrap web apps natively
Upstream URL:
Submitter: atnanasi
Maintainer: lostkhaos
Last Packager: lostkhaos
Votes: 38
Popularity: 1.76
First Submitted: 2016-02-20 05:39
Last Updated: 2019-08-22 20:09

Latest Comments

1 2 Next › Last »

jeremejevs commented on 2018-10-12 11:11

@lostkhaos Thank you!

lostkhaos commented on 2018-10-11 20:15

@jeremejevs nice. Folded in the guideline changes. Been mildly irritated by that permission problem too.

jeremejevs commented on 2018-10-11 16:24

@lostkhaos Please, take a look at the Node.js package guidelines: I personally am interested in the addition of the permission fix (777 vs. 755), but it also explains why the cache override suggested by @je-vv is needed. And why download the tarball, but not use it when installing? Here's a full PKGBUILD which appears to be inline with the guidelines:

lostkhaos commented on 2018-10-11 14:51

@je-vv, does this solve a build issue or is it a sanity thing? I tried with and without that line and compared the generated packages and they look pretty similar to me other than timestamps.

je-vv commented on 2018-10-11 01:33

Can you please add export npm_config_cache="$srcdir/npm_cache" prior to calling any nbm command? This will prevent dirtying other areas, and also will prevent as well picking caches from other/prior builds which have set this up.

lostkhaos commented on 2017-11-09 15:57

@balwierz indeed, npm warns you about this at least (although the comment that your version is out-of-date is incorrect). You can watch the issue on github to see when they fix it:

balwierz commented on 2017-11-09 13:24

It won't build with the future nodejs currently in community-testing:

$ npm --version
$ yaourt -Qa nodejs
community-testing/nodejs 9.1.0-1

==> Starting package()...
npm WARN npm npm does not support Node.js v9.1.0
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can't make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 4, 6, 7, 8.
npm WARN npm You can find the latest version at
WARNING: You are likely using a version of node-tar or npm that is incompatible with this version of Node.js.ock
Please use either the version of npm that is bundled with Node.js, or a version of npm (> 5.5.1 or < 5.4.0) or node-tar (> 4.0.1) that is compatible with Node.js 9 and above.
/usr/bin/node[8608]: ../src/ void node::{anonymous}::ZCtx::Init(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args.Length() == 7 && "init(windowBits, level, memLevel, strategy, writeResult, writeCallback," " dictionary)"' failed.
1: node::Abort() [npm]
2: node::Assert(char const* const (*) [4]) [npm]
3: 0x55f369e0e628 [npm]
4: v8::internal::FunctionCallbackArguments::Call(void (*)(v8::FunctionCallbackInfo<v8::Value> const&)) [npm]
5: 0x55f3696fafaf [npm]
6: 0x55f3696fb4ff [npm]
7: 0x14d0bd5842fd
/tmp/yaourt-tmp-foo/aur-nodejs-nativefier/./PKGBUILD: line 16: 8608 Aborted (core dumped) npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver

atnanasi commented on 2017-05-09 12:54

Sorry for late.
I updated it.

gromain commented on 2017-05-04 14:42

Version 7.3.1 is out! Here and

Could you please update?


gamezelda commented on 2017-04-03 17:59

I had to install extra/gconf for the generated apps to work, should be a dependency.