Package Details: nodejs-imapnotify-git 0.2.0.r6.ga37456c-1

Git Clone URL: https://aur.archlinux.org/nodejs-imapnotify-git.git (read-only)
Package Base: nodejs-imapnotify-git
Description: Execute scripts on new messages using IDLE imap command
Upstream URL: http://github.com/a-sk/node-imapnotify
Licenses: MIT
Conflicts: nodejs-imapnotify
Submitter: yourealwaysbe
Maintainer: yourealwaysbe
Last Packager: yourealwaysbe
Votes: 3
Popularity: 0.000005
First Submitted: 2015-01-10 19:01
Last Updated: 2017-11-01 18:01

Latest Comments

1 2 Next › Last »

Rhinoceros commented on 2017-11-01 21:40

Thank you!

yourealwaysbe commented on 2017-11-01 18:01

Done!

Rhinoceros commented on 2017-10-28 11:26

Oh BTW the versioning is slightly incorrect. Because there is a tag upstream, you should use the second version on the wiki, i.e.

git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'

This will mean that the latest git version will be installed as 0.2.0.r6.ga37456c . The current PKGBUILD makes the version r30.a37456c-1, which is actually less than the previously-installed version (i.e. pacman will not update it).

Rhinoceros commented on 2017-10-28 11:17

Thank you for the prompt fix! It installs perfectly now.

Re: python-imapnotify. Haha… yes I was the one that made the original comment referencing it on the nodejs-imapnotify package! :D I've just been having some problems recently with the python version, and wanted to try this one again. Thanks again.

yourealwaysbe commented on 2017-10-28 10:10

I have pushed a new version that hopefully fixes your error. Let me know if the problems continue.

Btw, there is also a python version which is now the developers main version. It is available also via the AUR: https://aur.archlinux.org/packages/python-imapnotify/

Rhinoceros commented on 2017-10-28 09:53

I copied the source of the symlinks manually from the pkg directory (after makepkg), but now it fails with

module.js:515
throw err;
^

Error: Cannot find module 'imap'
at Function.Module._resolveFilename (module.js:513:15)
at Function.Module._load (module.js:463:25)
at Module.require (module.js:556:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/usr/bin/imapnotify:3:12)
at Module._compile (module.js:612:30)
at Object.Module._extensions..js (module.js:623:10)
at Module.load (module.js:531:32)
at tryModuleLoad (module.js:494:12)
at Function.Module._load (module.js:486:3)

Rhinoceros commented on 2017-10-28 09:44

Hi again! This package still fails to install properly, but for different reasons now. It installs `/usr/bin/imapnotify`, which is a symlink to the non-existent `../lib/node_modules/imapnotify/bin/imapnotify`. It also installs `/usr/lib/node_modules/imapnotify`, which is a symlink to the non-existent `../../../../../src/nodejs-imapnotify-git`.

Rhinoceros commented on 2016-09-10 13:06

I get the following error when I install.

(1/1) installing nodejs-imapnotify-git
warning: directory permissions differ on /usr/bin/
filesystem: 755 package: 777

It's odd, because the package's usr/bin seems to have normal permissions (755). Maybe I don't understand this error…

yourealwaysbe commented on 2016-08-14 17:18

@tealeaf -- do you still have this issue? I just tried it and had no problems.

Apologies for the delay in responding.

tealeaf commented on 2016-08-01 12:00

I haven't seen this specifically mentioned here, although there seem to be a few related issues around the web.

I installed this fine about a week ago, but now when I run a package update, or reinstall from scratch, I get to the:
"==> Starting package()..."
line, and npm sits there using up about a quarter of my CPU without progressing.

I've run the relevant line from the PKGBUILD manually and it hangs on the first package install:
"[..................] | normalizeTree: sill install loadCurrentTree"

From a quick search, it seems that this is a known issue related to installing packages locally, but I haven't found if there is a well-known solution.