Package Details: nodejs-git 5.11.1.r4.g03d36ae-1

Git Clone URL: https://aur.archlinux.org/nodejs-git.git (read-only)
Package Base: nodejs-git
Description: Evented I/O for V8 javascript
Upstream URL: http://nodejs.org/
Licenses: MIT
Conflicts: nodejs
Provides: nodejs
Submitter: dcai
Maintainer: tuckerboniface
Last Packager: haawda
Votes: 9
Popularity: 0.000000
First Submitted: 2010-01-15 05:50
Last Updated: 2016-06-19 20:15

Required by (801)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

alperkanat commented on 2011-11-21 22:38

@vkumar: thanks for your efforts! i read everything in the ticket and there seems to be no interest on it yet. so do you have any suggestions? i didn't want to lose time to compile it as i know it won't. is there a change in the situation? do you still want me to apply your changes?

vkumar commented on 2011-11-15 18:29

Opened a bug report upstream: https://github.com/joyent/node/issues/2113#issuecomment-2746564
Hopefully we won't have to deal with this in the future.

vkumar commented on 2011-11-15 09:32

.. and after it compiled, make failed again because of another print statement.

vkumar commented on 2011-11-15 09:15

Hey, I had to add a few more sed statements to get node to even compile. More issues with python => python2, /usr/bin/env python => /usr/bin/env python2...

[code]

# python2 fix
for file in $(find . -name '*.py' -print) tools/gyp_node configure wscript tools/waf-light tools/node-waf; do
sed -i 's_^#!.*/usr/bin/python2*_#!/usr/bin/python2_' "$file"
sed -i 's_^#!.*/usr/bin/env.*python2*_#!/usr/bin/env python2_' "$file"
done

sed -i "s|cmd_R = 'python |cmd_R = 'python2 |" wscript
sed -i "s|python |python2 |" Makefile

for file in $(find . -name '*.gyp' -print) $(find . -name '*.txt' -print) configure tools/gyp_node vcbuild.bat; do
sed -i "s|python |python2 |" "$file"
done
[/code]

pumbur commented on 2011-11-05 12:30

"depends=('nodejs')" and "export NODE_PATH=/usr/lib/node_modules" > npm.sh, please

alperkanat commented on 2011-10-29 23:40

updated the package with absent files. thanks @johnhamelink

johnhamelink commented on 2011-10-21 08:35

Build fails with "install: cannot stat 'README.cmake': No such file or directory.

alperkanat commented on 2011-09-11 21:10

updated the package. it can now be compiled with gcc

Anonymous comment on 2011-07-16 09:44

current version in git does not compile with gcc4.6
v0.4.9 does

i added
git checkout v0.4.9
after
cd ${srcdir}/${_gitname}

to be able to install this pkg

alperkanat commented on 2011-06-12 22:58

made the changes of atondwal.. thanks!