Package Details: ninja-kitware 1.9.0-3

Git Clone URL: https://aur.archlinux.org/ninja-kitware.git (read-only)
Package Base: ninja-kitware
Description: Small build system with a focus on speed - Kitware version with JobServer and Fortran compatibility
Upstream URL: https://github.com/Kitware/ninja
Licenses: Apache
Conflicts: ninja
Provides: ninja
Submitter: phcerdan
Maintainer: phcerdan
Last Packager: phcerdan
Votes: 2
Popularity: 0.014029
First Submitted: 2018-05-23 15:37
Last Updated: 2019-03-27 12:58

Required by (455)

Sources (1)

Latest Comments

simonfxr commented on 2019-02-06 12:05

Sounds good to me, thank you phcerdan.

phcerdan commented on 2019-02-04 17:27

Updated to latest release, and also make emacs optdepends.

Not sure if the way I am handling the optdependency is standard, but seems to work. It will only compile and install the .el files if the executable emacs is present in the system at build time.

I created this PKGBUILD following ninja in community, which still has the emacs-nox. https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/ninja

Let me know if this works for you @simonfxr

phcerdan commented on 2019-02-01 14:28

Thanks simonxfr, I bluntly adapted the PKGBUILD from ninja-git, and they have changed it already. I will update soon.

simonfxr commented on 2019-02-01 14:22

Please do not directly builddepend on emacs-nox, this makes it impossible to install when emacs is present. Just depend on emacs, emacs-nox provides emacs.