Package Details: ninja-ide 2.4-2

Git Clone URL: https://aur.archlinux.org/ninja-ide.git (read-only, click to copy)
Package Base: ninja-ide
Description: Cross-platform IDE focused on Python application development
Upstream URL: http://ninja-ide.org
Licenses: GPL3
Submitter: arojas
Maintainer: Singularity
Last Packager: Singularity
Votes: 0
Popularity: 0.000000
First Submitted: 2018-08-24 08:06
Last Updated: 2021-01-03 07:33

Pinned Comments

Singularity commented on 2021-01-03 07:38

This package can be installed in parallel with ninja-ide-git.

Latest Comments

Singularity commented on 2021-01-03 07:38

This package can be installed in parallel with ninja-ide-git.

Singularity commented on 2020-03-29 23:07

Thanks for the report. I changed that, but didn't see that the url does not work, as I had the file already downloaded.

n0m commented on 2020-03-29 12:35

Hi, This file cannot be installed because there is no file 'https://github.com/ninja-ide/ninja-ide/releases/download/v$pkgver/$pkgname-$pkgver.zip" on github.

There are only files:

https://github.com/ninja-ide/ninja-ide/releases/download/v2.4/ninja-ide-2.4-installer.exe https://github.com/ninja-ide/ninja-ide/releases/download/v2.4/ninja-ide-2.4.deb https://github.com/ninja-ide/ninja-ide/releases/download/v2.4/ninja-ide-2.4.tar.gz

After some tests I found the easiest way to install it, just edit PKBUILD and replace line: https://github.com/ninja-ide/ninja-ide/releases/download/v$pkgver/$pkgname-$pkgver.zip with: https://github.com/ninja-ide/ninja-ide/archive/v2.4.zip

The zip file has the same sha256sum as in PKBUILD so maybe there were some changes on ninja-ide side.

phil.dubois commented on 2018-09-19 00:42

python2-pyqt is now python2-pyqt5

I also needed to install the unlisted dependency python2-sip

Lastly, I received the following error and solved it by installing python2-pyqt4:

==> Starting package()...
Module 'PyQt4' not found. For more details: '<http://www.riverbankcomputing.co.uk/software/pyqt/intro>'.

==> ERROR: A failure occurred in package().