Package Details: nightcode 2.8.1-2

Git Clone URL: https://aur.archlinux.org/nightcode.git (read-only)
Package Base: nightcode
Description: An IDE that bundles a smart editor, the Leiningen and Boot build tools, and a home screen with quick access to the Clojure cheatsheet and REPL.
Upstream URL: https://sekao.net/nightcode/
Keywords: clojure clojurescript editor
Licenses: custom
Conflicts: nightcode-git
Submitter: marcs
Maintainer: marcs
Last Packager: marcs
Votes: 2
Popularity: 0.000004
First Submitted: 2016-07-28 09:24
Last Updated: 2019-10-09 17:14

Latest Comments

marcs commented on 2019-02-06 13:32

Hey there @milaxnuts

I changed the dependency to jdk8-openjdk, I was unable to replicate your error but it seems that boot has some problems with jdk-openjdk (v11), at least on Arch (or my config). Ran boot -u after setting jdk8-openjdk as the default and the package built fine.

I used the archlinux-java command to set my default jdk.

milaxnuts commented on 2018-12-09 20:25

please consider hard-coding PATH="/usr/lib/jvm/java-8-openjdk/bin:$PATH" into the pkgbuild, and setting java-runtime=8 as dependency, as does closure-compiler

build requires

$ readlink -f /usr/lib/jvm/default
/usr/lib/jvm/java-8-openjdk
or
PATH="/usr/lib/jvm/java-8-openjdk/bin:$PATH" pikaur -S nightcode
otherwise (with java-10-openjdk) build fails with

==> Making package: nightcode 2.6.0-1 (Sun Dec  9 20:40:08 2018)
...
  -> Building nightcode...
Downloading https://github.com/boot-clj/boot/releases/download/2.7.2/boot.jar...
Running for the first time, BOOT_VERSION not set: updating to latest.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by dynapath.defaults$fn__1516$fn__1517 (file:/home/user/.boot/cache/lib/2.7.2/aether.uber.jar) to method java.net.URLClassLoader.addURL(java.net.URL)
WARNING: Please consider reporting this to the maintainers of dynapath.defaults$fn__1516$fn__1517
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
Retrieving clojure-1.9.0.pom from https://repo1.maven.org/maven2/ (10k)
...
Retrieving core.specs.alpha-0.1.24.jar from https://repo1.maven.org/maven2/ (4k)
#http://boot-clj.com
#Sun Dec 09 20:41:07 CET 2018
BOOT_VERSION=2.8.2
BOOT_CLOJURE_VERSION=1.9.0
BOOT_CLOJURE_NAME=org.clojure/clojure
==> Entering fakeroot environment...
==> Starting package()...
install: cannot stat '/home/user/.cache/pikaur/build/nightcode/src/Nightcode-2.6.0/target/project.jar': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...