Package Details: nfdump 1.6.19-1

Git Clone URL: https://aur.archlinux.org/nfdump.git (read-only, click to copy)
Package Base: nfdump
Description: A set of tools to collect and process netflow data.
Upstream URL: https://github.com/phaag/nfdump/
Licenses: BSD
Submitter: rudy.matela
Maintainer: rudy.matela
Last Packager: rudy.matela
Votes: 11
Popularity: 0.000000
First Submitted: 2008-12-21 03:56
Last Updated: 2020-03-25 16:34

Dependencies (1)

Required by (3)

Sources (4)

Latest Comments

1 2 3 Next › Last »

rudy.matela commented on 2020-03-25 16:35

Thanks @4le34n. I have released a new version with your contributions. Sorry for the delay on this.

4le34n commented on 2020-02-28 07:32

A little wrong last time. Here is a more correct version:

cat nfcapd@.service [Unit] Description=nfapd collector to port %i After=network.target

[Service] User=nfdump Group=http Type=forking ExecStart=/usr/bin/nfcapd -w -D -p %i -B 212992 -S 1 -P /run/nfdump/nfcapd.p%i.pid -z -I peer1-p%i -l /var/lib/nfdump/profiles-data/live/peer1-p%i PIDFile=/run/nfdump/nfcapd.p%i.pid

[Install] WantedBy=multi-user.target

4le34n commented on 2020-02-28 07:07

cat /usr/lib/tmpfiles.d/nfdump.conf d /run/nfdump 0755 nfdump nfdump -

cat /usr/lib/sysusers.d/nfdump.conf u nfdump - "nfdump user" /var/lib/nfdump /usr/bin/false

4le34n commented on 2020-02-28 07:05

Multiple instance nfcapd service:

cat /usr/lib/systemd/system/nfcapd@.service

[Unit] Description=nfapd collector to port %i After=network.target

[Service] User=nfdump Group=http Type=forking ExecStart=/usr/bin/nfcapd -w -D -p %i -S 1 -P /run/nfdump/nfcapd.p%i.pid -z -I router1 -l /var/lib/nfdump/profiles-data/live/router1 PIDFile=/run/nfdump/nfcapd.p%i.pid

[Install] WantedBy=multi-user.target

rudy.matela commented on 2018-10-16 00:15

@wespe Yes, pkgconf is a build dependency but it does not need to be explicitly listed. All packages in AUR assume that the base-devel group is installed for compilation. See also the AUR: Getting Started wiki page section.

But now that you mention it, I saw that the dependencies included two packages that are in base-devel: flex and bison. I have removed them and released 1.6.17-2.

I have also moved rrdtool from makedepends to depends as it is also needed to run the tool in addition to compiling it.

wespe commented on 2018-10-15 15:17

pkgconf is a dependency

rudy.matela commented on 2017-11-23 10:39

New version 1.6.16-1 is out.

rudy.matela commented on 2017-11-23 10:35

New version 1.6.15-4 is out.

This fixes the build issue reported by @starfry.

@starfry, thanks for reporting the issue and the fix. If you like, I can add you as a co-maintainer for this package.

starfry commented on 2017-11-22 18:57

Hi, I got a slightly different error today:

libtool: Version mismatch error. This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.6.40-6ca5.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.

I fixed it by changing the PKGBUILD. From 'autoreconf' to 'autoreconf --force --install' which I did after reading https://stackoverflow.com/a/3205400.

rudy.matela commented on 2017-07-28 13:24

New version 1.16.15-3 is out.

This fixes the build issue reported by @zavdnw.

Thanks to @zavndw for reporting the issue and to @4le34n fox the fix.